This hunt detects adversary behavior indicative of Cobalt Strike beacon deployment by identifying specific Indicators of Compromise (IOCs) known to facilitate command and control communications. Proactively hunting for these IOCs in Azure Sentinel is critical because early identification of this widely used post-exploitation tool allows the SOC team to isolate compromised assets before lateral movement or data exfiltration occurs.
Malware Family: Cobalt Strike Total IOCs: 3 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 151[.]239[.]24[.]33:9090 | botnet_cc | 2026-07-13 | 100% |
| ip:port | 64[.]90[.]13[.]61:80 | botnet_cc | 2026-07-13 | 100% |
| ip:port | 106[.]54[.]44[.]181:81 | botnet_cc | 2026-07-13 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Cobalt Strike
let malicious_ips = dynamic(["106.54.44.181", "64.90.13.61", "151.239.24.33"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["106.54.44.181", "64.90.13.61", "151.239.24.33"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are 4 specific false positive scenarios for the ThreatFox: Cobalt Strike IOCs detection rule in an enterprise environment, including suggested filters and exclusions:
Endpoint Protection Scanner Updates
svc_crowdstrike, LocalSystem running MsMpEng.exe) or whitelist the known IP ranges of the EDR vendor’s update servers in the detection logic.IT Asset Inventory Scans
C:\Program Files\Tenable\Nessus\nessus.exe or C:\ProgramData\Qualys\Agent\qualys-agent-service.exe) and restrict the rule to only flag traffic originating from user workstations rather than dedicated scan servers.Software Deployment via SCCM/Intune