This hunt detects adversary behavior characterized by the deployment of Cobalt Strike beacons and their associated infrastructure indicators across the Azure environment. Proactively hunting for these specific IOCs is critical to identify early-stage lateral movement and command-and-control communications before they evolve into full-scale post-exploitation campaigns.
Malware Family: Cobalt Strike Total IOCs: 21 IOC Types: url, ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 59[.]110[.]23[.]216:443 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 101[.]42[.]255[.]92:8081 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 140[.]143[.]239[.]224:8050 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 119[.]45[.]160[.]160:8080 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 117[.]72[.]175[.]125:8080 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 119[.]45[.]160[.]160:443 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 119[.]45[.]160[.]160:80 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 114[.]132[.]89[.]132:51443 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 116[.]198[.]233[.]179:8080 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 38[.]54[.]61[.]225:80 | botnet_cc | 2026-07-10 | 75% |
| ip:port | 101[.]34[.]235[.]198:8443 | botnet_cc | 2026-07-10 | 75% |
| url | hxxp://158[.]178[.]230[.]77:7443/3Jms | botnet_cc | 2026-07-10 | 75% |
| ip:port | 158[.]178[.]230[.]77:7443 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 8[.]134[.]70[.]73:80 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 39[.]105[.]201[.]165:8080 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 39[.]105[.]201[.]165:80 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 39[.]105[.]201[.]165:443 | botnet_cc | 2026-07-10 | 100% |
| url | hxxp://62[.]234[.]54[.]51:443/ga.js | botnet_cc | 2026-07-10 | 75% |
| url | hxxp://62[.]234[.]54[.]51:443/DCqe | botnet_cc | 2026-07-10 | 75% |
| ip:port | 78[.]17[.]212[.]136:443 | botnet_cc | 2026-07-09 | 75% |
| ip:port | 59[.]110[.]23[.]216:8181 | botnet_cc | 2026-07-09 | 75% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Cobalt Strike
let malicious_ips = dynamic(["59.110.23.216", "114.132.89.132", "101.42.255.92", "38.54.61.225", "78.17.212.136", "116.198.233.179", "39.105.201.165", "119.45.160.160", "158.178.230.77", "117.72.175.125", "140.143.239.224", "101.34.235.198", "8.134.70.73"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["59.110.23.216", "114.132.89.132", "101.42.255.92", "38.54.61.225", "78.17.212.136", "116.198.233.179", "39.105.201.165", "119.45.160.160", "158.178.230.77", "117.72.175.125", "140.143.239.224", "101.34.235.198", "8.134.70.73"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Cobalt Strike
let malicious_urls = dynamic(["http://158.178.230.77:7443/3Jms", "http://62.234.54.51:443/ga.js", "http://62.234.54.51:443/DCqe"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: Cobalt Strike IOCs rule, including suggested filters and exclusions tailored for an enterprise environment:
Endpoint Protection Scanning of Quarantine Archives
C:\Program Files\CrowdStrike\csagent.exe or MsMpEng.exe) when the file path contains \Quarantine\, \Samples\, or \Archive\.Software Deployment via SCCM/Intune
ccmexec.exe) unpacks and stages these files in C:\Windows\CCMCache, the file hashes match the detection IOCs, generating alerts despite the activity being part of an authorized change management ticket.ccmexec.exe or IntuneManagementExtension.exe and the destination path is within the standard software distribution cache (e.g., C:\Windows\CCMCache\*).**Scheduled Network Traffic