This hunt hypothesis targets adversaries leveraging Cobalt Strike beacons to establish persistent command-and-control channels and execute lateral movement within the network. Proactively hunting for these specific IOCs in Azure Sentinel is critical because early detection of this widely used post-exploitation tool allows the SOC team to disrupt active intrusions before they escalate into significant data exfiltration or ransomware deployment events.
Malware Family: Cobalt Strike Total IOCs: 20 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 154[.]12[.]85[.]75:80 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 47[.]116[.]60[.]211:8443 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 159[.]75[.]195[.]231:5004 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 119[.]45[.]160[.]160:111 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 51[.]222[.]87[.]16:22 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 51[.]222[.]87[.]16:21 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]33[.]225[.]32:123 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]42[.]255[.]92:8082 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]42[.]255[.]92:5353 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]33[.]225[.]32:3306 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]42[.]255[.]92:137 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]33[.]225[.]32:22 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]33[.]225[.]32:13306 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 49[.]233[.]136[.]227:18082 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 49[.]233[.]136[.]227:22 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 47[.]108[.]60[.]27:22 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]200[.]193[.]211:8000 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 101[.]200[.]193[.]211:44321 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 38[.]76[.]169[.]75:870 | botnet_cc | 2026-07-18 | 75% |
| ip:port | 130[.]94[.]34[.]66:6666 | botnet_cc | 2026-07-18 | 75% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Cobalt Strike
let malicious_ips = dynamic(["130.94.34.66", "101.42.255.92", "51.222.87.16", "47.108.60.27", "101.200.193.211", "119.45.160.160", "154.12.85.75", "159.75.195.231", "47.116.60.211", "49.233.136.227", "38.76.169.75", "101.33.225.32"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["130.94.34.66", "101.42.255.92", "51.222.87.16", "47.108.60.27", "101.200.193.211", "119.45.160.160", "154.12.85.75", "159.75.195.231", "47.116.60.211", "49.233.136.227", "38.76.169.75", "101.33.225.32"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios for the ThreatFox: Cobalt Strike IOCs detection rule in an enterprise environment, along with suggested filters or exclusions:
Software Deployment via SCCM/Intune: System administrators often deploy the official “Cobalt Strike” tool (or its underlying Java runtime components) to specific engineering workstations for authorized network scanning and vulnerability assessment. The deployment process triggers file creation and registry modifications matching the 20 IOCs.
Software Center service account (NT SERVICE\SCCM) and the specific deployment collection ID for “Security Engineering.”Scheduled Vulnerability Scans: The enterprise security team runs a weekly scheduled job using a third-party scanner (e.g., Tenable Nessus or Qualys) that utilizes Cobalt Strike’s beacon architecture to simulate lateral movement during penetration testing windows. These scans generate network traffic and process executions identical to the threat IOCs but are time-bound.
Tenable Agent service (TENAGENT) when running from the designated “Penetration Test” subnet (e.g., 10.50.20.0/24).Red Team Exercises: Internal Red Teams frequently conduct authorized simulation exercises where they deploy Cobalt Strike beacons to test detection capabilities. These activities involve legitimate execution of the beacon.exe binary and associated DLLs, which are indistinguishable from malicious activity without context.