This hunt detects adversary behavior consistent with Cobalt Strike deployments by identifying matches against a curated set of 27 known indicators of compromise across network and host telemetry. Proactively hunting for these signatures in Azure Sentinel is critical because Cobalt Strike is frequently used as a command-and-control framework during active intrusions, allowing the SOC team to rapidly identify and contain sophisticated lateral movement before it escalates into a full breach.
Malware Family: Cobalt Strike Total IOCs: 27 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 8[.]163[.]93[.]232:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 8[.]163[.]93[.]232:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 39[.]105[.]200[.]188:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 49[.]234[.]198[.]180:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 39[.]106[.]113[.]249:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 139[.]226[.]191[.]149:2082 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 47[.]96[.]254[.]114:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 47[.]96[.]254[.]114:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 47[.]116[.]57[.]211:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 47[.]116[.]57[.]211:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 39[.]106[.]80[.]126:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 172[.]245[.]226[.]120:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 39[.]106[.]80[.]126:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 159[.]75[.]195[.]231:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 141[.]255[.]162[.]234:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 159[.]75[.]195[.]231:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 123[.]184[.]9[.]84:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 141[.]255[.]162[.]234:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 123[.]184[.]9[.]84:443 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 123[.]184[.]9[.]84:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 121[.]43[.]181[.]37:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 121[.]43[.]181[.]37:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 117[.]72[.]159[.]96:8080 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 117[.]72[.]159[.]96:80 | botnet_cc | 2026-07-08 | 100% |
| ip:port | 107[.]173[.]85[.]194:8080 | botnet_cc | 2026-07-08 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Cobalt Strike
let malicious_ips = dynamic(["107.173.85.194", "159.75.195.231", "39.105.200.188", "103.42.30.154", "141.255.162.234", "39.106.80.126", "123.184.9.84", "39.106.113.249", "117.72.159.96", "172.245.226.120", "121.43.181.37", "8.163.93.232", "47.116.57.211", "139.226.191.149", "49.234.198.180", "111.229.248.198", "47.96.254.114"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["107.173.85.194", "159.75.195.231", "39.105.200.188", "103.42.30.154", "141.255.162.234", "39.106.80.126", "123.184.9.84", "39.106.113.249", "117.72.159.96", "172.245.226.120", "121.43.181.37", "8.163.93.232", "47.116.57.211", "139.226.191.149", "49.234.198.180", "111.229.248.198", "47.96.254.114"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: Cobalt Strike IOCs detection rule, including suggested filters and exclusions tailored for an enterprise environment:
Software Deployment via SCCM/Intune
ProcessName of the installer (e.g., ccmsetup.exe, intune-management-agent) and restrict the alert scope to specific OU paths (e.g., OU=Engineering,DC=corp,DC=local) or a dedicated Asset Group known for running this tool.Scheduled Vulnerability Scanning Jobs
02:00 - 04:00 UTC). Additionally, exclude specific Service Accounts used by the scanner (e.g., svc-tenable-scan) from triggering this rule on critical infrastructure servers.Red Team Exercise and Internal Penetration Testing *