This hunt detects adversary activity consistent with the DCRat remote access trojan by identifying specific indicators of compromise across network and endpoint telemetry within Azure Sentinel. Proactively hunting for these signatures is critical to rapidly identify early-stage lateral movement or command-and-control communications before they escalate into a full-blown data exfiltration incident.
Malware Family: DCRat Total IOCs: 4 IOC Types: domain, url, ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 144[.]172[.]88[.]233:5656 | botnet_cc | 2026-07-18 | 75% |
| domain | nuevocomienzp333.duckdns.org | botnet_cc | 2026-07-18 | 100% |
| domain | gfhdsjkasd.duckdns.org | botnet_cc | 2026-07-18 | 100% |
| url | hxxps://store.julias.makeup/img_094957.png | payload_delivery | 2026-07-18 | 50% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - DCRat
let malicious_ips = dynamic(["144.172.88.233"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["144.172.88.233"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - DCRat
let malicious_domains = dynamic(["nuevocomienzp333.duckdns.org", "gfhdsjkasd.duckdns.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - DCRat
let malicious_urls = dynamic(["https://store.julias.makeup/img_094957.png"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are four specific false positive scenarios for the ThreatFox: DCRat IOCs detection rule in an enterprise environment, along with suggested filters or exclusions:
Enterprise Antivirus Signature Updates via Scheduled Tasks
SYSTEM account during off-hours (e.g., 02:00 AM).NT AUTHORITY\SYSTEM and the parent process is the specific AV updater service (e.g., falcon.sys or MsMpEng.exe). Additionally, add a time-based exclusion to suppress alerts generated between 01:00 and 04:00 UTC.IT Asset Management & Patch Deployment Tools
ccmexec.exe) or Ivanti agent, specifically filtering for events originating from the “IT Operations” Organizational Unit (OU) in Active Directory.Internal Development Build Pipelines