This hunt targets the presence of known PureRAT indicators of compromise, which are frequently used by adversaries to establish persistent remote access and execute malicious payloads on compromised endpoints. Proactively hunting for these IOCs in Azure Sentinel allows the SOC team to identify and isolate infected assets before the ransomware-as-a-service tool can be leveraged for lateral movement or data exfiltration.
Malware Family: PureRAT Total IOCs: 37 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 82[.]22[.]7[.]20:5069 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 108[.]187[.]43[.]137:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 108[.]187[.]43[.]144:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 89[.]23[.]107[.]16:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 89[.]23[.]107[.]16:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 89[.]23[.]107[.]16:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 145[.]249[.]115[.]103:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 145[.]249[.]115[.]103:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 145[.]249[.]115[.]103:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 145[.]249[.]115[.]252:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 145[.]249[.]115[.]252:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 145[.]249[.]115[.]252:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 153[.]80[.]240[.]86:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 154[.]36[.]188[.]246:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 154[.]36[.]188[.]246:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 192[.]163[.]162[.]72:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 192[.]163[.]162[.]72:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 192[.]163[.]162[.]72:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 177[.]5[.]78[.]71:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 177[.]5[.]78[.]71:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 156[.]240[.]108[.]46:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 177[.]5[.]78[.]71:56003 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 156[.]240[.]108[.]46:56001 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 156[.]240[.]108[.]46:56002 | botnet_cc | 2026-09-06 | 75% |
| ip:port | 179[.]236[.]107[.]22:56001 | botnet_cc | 2026-09-06 | 75% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - PureRAT
let malicious_ips = dynamic(["144.172.65.241", "179.236.107.40", "179.236.107.22", "154.36.188.246", "82.22.7.20", "144.172.65.6", "177.5.78.71", "108.187.43.137", "153.80.240.86", "104.194.135.149", "145.249.115.252", "104.194.135.211", "192.163.162.72", "153.75.94.222", "104.194.135.115", "89.23.107.16", "144.172.65.156", "108.187.43.144", "145.249.115.103", "156.240.108.46"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["144.172.65.241", "179.236.107.40", "179.236.107.22", "154.36.188.246", "82.22.7.20", "144.172.65.6", "177.5.78.71", "108.187.43.137", "153.80.240.86", "104.194.135.149", "145.249.115.252", "104.194.135.211", "192.163.162.72", "153.75.94.222", "104.194.135.115", "89.23.107.16", "144.172.65.156", "108.187.43.144", "145.249.115.103", "156.240.108.46"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
svc-ci-builder) or paths within the build infrastructure directory (e.g., C:\BuildAgents\).VeeamBackup.exe, AcronisBackup.exe) or processes launched by known service accounts (e.g., svc-backup-service).temp.ps1 in a specific user profile).
CommandLine contains specific scheduled task identifiers (e.g., -ExecutionPolicy Bypass -File C:\Scripts\LogCleanup.ps1) or processes owned by the SYSTEM account in standard system paths.C:\Users\<dev>\Desktop\test\.
C:\Users\*) where the parent process is a development IDE (e.g., code.exe, devenv.exe, idea64.exe) or a terminal emulator (e.g., cmd.exe,