This hunt targets adversary behavior consistent with the Remcos remote access trojan by actively scanning Azure Sentinel logs against a curated set of 16 known indicators of compromise. Proactively hunting for these specific IOCs is critical to detect early-stage lateral movement and command-and-control communications before they escalate into full-scale data exfiltration incidents.
Malware Family: Remcos Total IOCs: 16 IOC Types: ip:port, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 45[.]155[.]69[.]97:1202 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 185[.]122[.]171[.]65:5691 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 185[.]122[.]171[.]124:8015 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 155[.]103[.]69[.]30:14641 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 155[.]103[.]69[.]30:14645 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 155[.]103[.]69[.]30:14646 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 103[.]11[.]41[.]20:4734 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 103[.]11[.]41[.]19:61502 | botnet_cc | 2026-07-02 | 75% |
| ip:port | 103[.]11[.]41[.]10:62534 | botnet_cc | 2026-07-02 | 75% |
| domain | yom.mefound.com | botnet_cc | 2026-07-02 | 75% |
| ip:port | 198[.]135[.]55[.]140:2404 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 185[.]149[.]24[.]6:2444 | botnet_cc | 2026-07-02 | 100% |
| domain | www.larmentybackup2.com | botnet_cc | 2026-07-02 | 75% |
| domain | www.larmenty.com | botnet_cc | 2026-07-02 | 75% |
| domain | www.larmentyback2.com | botnet_cc | 2026-07-02 | 75% |
| domain | www.larmentybackup1.com | botnet_cc | 2026-07-02 | 75% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Remcos
let malicious_ips = dynamic(["103.11.41.20", "185.122.171.124", "103.11.41.10", "103.11.41.19", "185.122.171.65", "155.103.69.30", "198.135.55.140", "45.155.69.97", "185.149.24.6"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["103.11.41.20", "185.122.171.124", "103.11.41.10", "103.11.41.19", "185.122.171.65", "155.103.69.30", "198.135.55.140", "45.155.69.97", "185.149.24.6"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Remcos
let malicious_domains = dynamic(["yom.mefound.com", "www.larmentybackup2.com", "www.larmenty.com", "www.larmentyback2.com", "www.larmentybackup1.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: Remcos IOCs detection rule in an enterprise environment, along with targeted filters and exclusions:
Antivirus Definition Updates via Scheduled Tasks
NT AUTHORITY\SYSTEM, LocalService) running specific scheduled tasks identified by their GUIDs. Additionally, whitelist the internal IP ranges of the organization’s patch management servers (e.g., WSUS or SCCM servers) from the network traffic analysis portion of the rule.Software Deployment via Configuration Management Tools
DOMAIN\DeploySvc) during defined maintenance windows (e.g., 02:00–04:00 UTC). Cross-reference the file hashes against an internal “Trusted Software Inventory” database to suppress alerts for known application versions.Remote Administration Sessions via RDP/VNC