← Back to SOC feed Coverage →

ThreatFox: Remcos IOCs

ioc-hunt HIGH ThreatFox
CommonSecurityLogDeviceNetworkEventsDnsEvents
iocthreatfoxwin-remcos
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-07-15T11:00:00Z · Confidence: high

Hunt Hypothesis

This hunt detects adversary activity consistent with the Remcos remote access trojan by identifying matches against its known indicators of compromise within Azure Sentinel logs. Proactively hunting for these signatures is critical to rapidly identify and contain potential data exfiltration or command-and-control communications before they escalate into a full-scale breach.

IOC Summary

Malware Family: Remcos Total IOCs: 17 IOC Types: ip:port, domain

TypeValueThreat TypeFirst SeenConfidence
ip:port204[.]44[.]69[.]214:14646botnet_cc2026-07-1575%
ip:port192[.]255[.]195[.]147:14645botnet_cc2026-07-1575%
ip:port124[.]198[.]132[.]119:5220botnet_cc2026-07-1575%
ip:port103[.]11[.]41[.]10:62452botnet_cc2026-07-1575%
ip:port103[.]11[.]41[.]10:10443botnet_cc2026-07-1575%
domainpajp.oragh8kaso1.combotnet_cc2026-07-1575%
domaingros59kalmso1.duckdns.orgbotnet_cc2026-07-1575%
domaingros59kalmso2.duckdns.orgbotnet_cc2026-07-1575%
domainmetromachine[.]4nmn.combotnet_cc2026-07-1575%
domainarmcobarriersuppliers.duckdns.orgbotnet_cc2026-07-1575%
domainarmcobarriersuppliersbk.duckdns.orgbotnet_cc2026-07-1575%
ip:port102[.]220[.]160[.]104:2404botnet_cc2026-07-1575%
ip:port161[.]248[.]179[.]182:37171botnet_cc2026-07-1575%
ip:port130[.]12[.]182[.]47:2404botnet_cc2026-07-1575%
ip:port194[.]59[.]31[.]232:2404botnet_cc2026-07-1575%
ip:port165[.]227[.]80[.]236:443botnet_cc2026-07-1575%
ip:port160[.]25[.]72[.]34:2404botnet_cc2026-07-1575%

KQL: Ip Hunt

// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Remcos
let malicious_ips = dynamic(["102.220.160.104", "160.25.72.34", "204.44.69.214", "103.11.41.10", "165.227.80.236", "124.198.132.119", "130.12.182.47", "192.255.195.147", "194.59.31.232", "161.248.179.182"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc

KQL: Ip Hunt Device

// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["102.220.160.104", "160.25.72.34", "204.44.69.214", "103.11.41.10", "165.227.80.236", "124.198.132.119", "130.12.182.47", "192.255.195.147", "194.59.31.232", "161.248.179.182"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Remcos
let malicious_domains = dynamic(["pajp.oragh8kaso1.com", "gros59kalmso1.duckdns.org", "gros59kalmso2.duckdns.org", "metromachine.4nmn.com", "armcobarriersuppliers.duckdns.org", "armcobarriersuppliersbk.duckdns.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DeviceNetworkEventsEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Here are 5 specific false positive scenarios for the ThreatFox: Remcos IOCs detection rule in an enterprise environment, along with suggested filters or exclusions:

Original source: https://threatfox.abuse.ch/browse/malware/win.remcos/