← Back to SOC feed Coverage →

ThreatFox: Sliver IOCs

ioc-hunt HIGH ThreatFox
CommonSecurityLogDeviceNetworkEvents
iocthreatfoxwin-sliver
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-09-27T23:00:00Z · Confidence: high

Hunt Hypothesis

This rule detects the presence of Sliver post-exploitation malware, which adversaries deploy to establish persistent access, execute arbitrary commands, and exfiltrate sensitive data following initial compromise. Proactively hunting for these IOCs in Azure Sentinel is critical to identify hidden footholds and lateral movement activities before the threat actor can fully establish control or exfiltrate critical assets.

IOC Summary

Malware Family: Sliver Total IOCs: 60 IOC Types: ip:port

TypeValueThreat TypeFirst SeenConfidence
ip:port94[.]237[.]62[.]102:31337botnet_cc2026-09-2750%
ip:port94[.]154[.]43[.]217:31337botnet_cc2026-09-2750%
ip:port94[.]103[.]2[.]70:31337botnet_cc2026-09-2750%
ip:port91[.]199[.]32[.]35:31337botnet_cc2026-09-2750%
ip:port89[.]125[.]50[.]85:31337botnet_cc2026-09-2750%
ip:port89[.]106[.]83[.]214:31337botnet_cc2026-09-2750%
ip:port82[.]29[.]53[.]100:31337botnet_cc2026-09-2750%
ip:port84[.]247[.]191[.]49:31337botnet_cc2026-09-2750%
ip:port82[.]25[.]63[.]33:31337botnet_cc2026-09-2750%
ip:port81[.]17[.]100[.]251:31337botnet_cc2026-09-2750%
ip:port79[.]137[.]77[.]63:31337botnet_cc2026-09-2750%
ip:port77[.]42[.]75[.]230:31337botnet_cc2026-09-2750%
ip:port74[.]0[.]42[.]242:4443botnet_cc2026-09-2750%
ip:port64[.]23[.]254[.]205:31337botnet_cc2026-09-2750%
ip:port66[.]42[.]33[.]224:31337botnet_cc2026-09-2750%
ip:port62[.]69[.]131[.]43:31337botnet_cc2026-09-2750%
ip:port46[.]19[.]140[.]40:31337botnet_cc2026-09-2750%
ip:port45[.]74[.]36[.]153:31337botnet_cc2026-09-2750%
ip:port45[.]197[.]12[.]215:31337botnet_cc2026-09-2750%
ip:port45[.]38[.]20[.]103:31337botnet_cc2026-09-2750%
ip:port45[.]125[.]67[.]3:31337botnet_cc2026-09-2750%
ip:port43[.]173[.]13[.]35:31337botnet_cc2026-09-2750%
ip:port43[.]163[.]208[.]239:31337botnet_cc2026-09-2750%
ip:port42[.]112[.]213[.]93:31337botnet_cc2026-09-2750%
ip:port24[.]144[.]71[.]145:31337botnet_cc2026-09-2750%

KQL: Ip Hunt

// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Sliver
let malicious_ips = dynamic(["147.50.242.137", "210.16.67.195", "162.33.178.10", "46.19.140.40", "94.154.43.217", "192.253.248.18", "43.173.13.35", "89.125.50.85", "166.88.77.149", "38.60.125.189", "91.199.32.35", "45.125.67.3", "129.204.144.48", "82.29.53.100", "77.42.75.230", "66.42.33.224", "193.149.129.2", "184.107.160.151", "138.16.183.115", "24.144.71.145", "82.25.63.33", "198.144.183.169", "62.69.131.43", "64.23.254.205", "180.94.20.228", "185.223.252.36", "156.240.236.11", "154.219.101.56", "142.93.58.98", "163.53.219.180", "42.112.213.93", "84.247.191.49", "187.145.61.38", "103.238.235.171", "168.110.125.3", "146.59.63.41", "194.226.187.161", "43.163.208.239", "89.106.83.214", "81.17.100.251", "45.74.36.153", "210.16.65.229", "158.178.225.215", "94.103.2.70", "45.197.12.215", "163.53.219.87", "94.237.62.102", "104.223.75.156", "146.19.125.102", "157.254.167.106"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc

KQL: Ip Hunt Device

// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["147.50.242.137", "210.16.67.195", "162.33.178.10", "46.19.140.40", "94.154.43.217", "192.253.248.18", "43.173.13.35", "89.125.50.85", "166.88.77.149", "38.60.125.189", "91.199.32.35", "45.125.67.3", "129.204.144.48", "82.29.53.100", "77.42.75.230", "66.42.33.224", "193.149.129.2", "184.107.160.151", "138.16.183.115", "24.144.71.145", "82.25.63.33", "198.144.183.169", "62.69.131.43", "64.23.254.205", "180.94.20.228", "185.223.252.36", "156.240.236.11", "154.219.101.56", "142.93.58.98", "163.53.219.180", "42.112.213.93", "84.247.191.49", "187.145.61.38", "103.238.235.171", "168.110.125.3", "146.59.63.41", "194.226.187.161", "43.163.208.239", "89.106.83.214", "81.17.100.251", "45.74.36.153", "210.16.65.229", "158.178.225.215", "94.103.2.70", "45.197.12.215", "163.53.219.87", "94.237.62.102", "104.223.75.156", "146.19.125.102", "157.254.167.106"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DeviceNetworkEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://threatfox.abuse.ch/browse/malware/win.sliver/