← Back to SOC feed Coverage →

ThreatFox: ValleyRAT IOCs

ioc-hunt HIGH ThreatFox
DeviceFileEvents
backdooriocthreatfoxwin-valley_rat
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-08-25T23:00:00Z · Confidence: high

Hunt Hypothesis

This hunt detects adversary activity involving the execution of known ValleyRAT indicators of compromise to identify potential remote access trojan infections within the environment. The SOC team should proactively search for these IOCs in Azure Sentinel to rapidly discover and contain early-stage compromises that could lead to credential theft or lateral movement before they escalate into broader incidents.

IOC Summary

Malware Family: ValleyRAT Total IOCs: 15 IOC Types: sha1_hash, md5_hash, sha256_hash

TypeValueThreat TypeFirst SeenConfidence
sha256_hashee2579b3b0776a20be98c1cb605cd7eb39909951320b375e6aacfbd230104572payload2026-08-2595%
sha1_hash2e26a2fbd74b1e40119e1031d4776d1c55efcf5cpayload2026-08-2595%
md5_hash59ae169e146ffcc328c53b0feade92cbpayload2026-08-2595%
sha256_hash00df868e2b8a8f4014ac129bb65bb8b0d7e196966e5b30b44390dbb3914d219epayload2026-08-2595%
sha1_hash42e83488d452064f0628a22bb038d36fc1e45d3epayload2026-08-2595%
md5_hash9165819cd48cc6eb816b22a27f85aefepayload2026-08-2595%
sha1_hash7d6142cfa025c44c947588f283c0275db4a24802payload2026-08-2595%
md5_hash8e168e0cacef78f10dc13a69d5bd0b1apayload2026-08-2595%
sha256_hash0b1d575c0c0a08ef48683113372d7580a42acfac4442a3927314b86dff616c4epayload2026-08-2595%
sha1_hash41cb7ed17731f8c1561399b381f42de3febcd6bepayload2026-08-2595%
md5_hash51f9befcc514d4468197647968767773payload2026-08-2595%
sha1_hasha2a89a44d71f06730e57843f96ade00667b4f90apayload2026-08-2595%
md5_hash5021094d588a1cc1f2cc9b61c717fda6payload2026-08-2595%
sha256_hashde993daff7d97c547bc608c9e5f0233ca1f420adb4931d8615171c7ec8182849payload2026-08-2595%
sha256_hash99328f02c062e6f2d52c257e7df219789f9ef0d9167444b2d123c78bba75362bpayload2026-08-2595%

KQL: Hash Hunt

// Hunt for files matching known malicious hashes
// Source: ThreatFox - ValleyRAT
let malicious_hashes = dynamic(["ee2579b3b0776a20be98c1cb605cd7eb39909951320b375e6aacfbd230104572", "2e26a2fbd74b1e40119e1031d4776d1c55efcf5c", "59ae169e146ffcc328c53b0feade92cb", "00df868e2b8a8f4014ac129bb65bb8b0d7e196966e5b30b44390dbb3914d219e", "42e83488d452064f0628a22bb038d36fc1e45d3e", "9165819cd48cc6eb816b22a27f85aefe", "7d6142cfa025c44c947588f283c0275db4a24802", "8e168e0cacef78f10dc13a69d5bd0b1a", "0b1d575c0c0a08ef48683113372d7580a42acfac4442a3927314b86dff616c4e", "41cb7ed17731f8c1561399b381f42de3febcd6be", "51f9befcc514d4468197647968767773", "a2a89a44d71f06730e57843f96ade00667b4f90a", "5021094d588a1cc1f2cc9b61c717fda6", "de993daff7d97c547bc608c9e5f0233ca1f420adb4931d8615171c7ec8182849", "99328f02c062e6f2d52c257e7df219789f9ef0d9167444b2d123c78bba75362b"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DeviceFileEventsEnsure this data connector is enabled

References

False Positive Guidance

Here are 4 specific false positive scenarios for the ThreatFox: ValleyRAT IOCs detection rule, along with recommended filters and exclusions tailored for an enterprise environment:

Original source: https://threatfox.abuse.ch/browse/malware/win.valley_rat/