This hunt detects adversary behavior involving the deployment of Vidar malware by matching network and endpoint telemetry against a curated set of 25 known indicators of compromise (IOCs). A SOC team should proactively hunt for these signals in Azure Sentinel to rapidly identify active infections, as Vidar’s modular architecture allows it to persist undetected while exfiltrating sensitive data before traditional alerts trigger.
Malware Family: Vidar Total IOCs: 25 IOC Types: url, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| domain | byz.sm188dadu.top | botnet_cc | 2026-08-15 | 100% |
| url | hxxps://byz.sm188dadu.top/ | botnet_cc | 2026-08-15 | 100% |
| domain | byz[.]10001slot.org | botnet_cc | 2026-08-15 | 100% |
| url | hxxps://byz[.]10001slot.org/ | botnet_cc | 2026-08-15 | 100% |
| url | hxxps://steamcommunity.com/profiles/76561198657426610 | botnet_cc | 2026-08-15 | 100% |
| url | hxxps://2[.]28[.]26[.]204 | botnet_cc | 2026-08-15 | 100% |
| url | hxxps://telegram.me/m1duus | botnet_cc | 2026-08-15 | 100% |
| domain | gru.sm188dadu.top | botnet_cc | 2026-08-14 | 100% |
| domain | gru[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://89[.]167[.]3[.]143 | botnet_cc | 2026-08-14 | 75% |
| domain | boi.sm188dadu.top | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://boi.sm188dadu.top/ | botnet_cc | 2026-08-14 | 100% |
| domain | boi[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://boi[.]10001slot.org/ | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://nu7.sm188dadu.top/ | botnet_cc | 2026-08-14 | 100% |
| domain | nu7.sm188dadu.top | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://nu7[.]10001slot.org/ | botnet_cc | 2026-08-14 | 100% |
| domain | nu7[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| domain | poh.sm188dadu.top | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://poh.sm188dadu.top/ | botnet_cc | 2026-08-14 | 100% |
| domain | poh[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://kee[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://xdr[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://tip[.]10001slot.org | botnet_cc | 2026-08-14 | 100% |
| url | hxxps://kee.sm188dadu.top | botnet_cc | 2026-08-14 | 100% |
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Vidar
let malicious_domains = dynamic(["byz.sm188dadu.top", "byz.10001slot.org", "gru.sm188dadu.top", "gru.10001slot.org", "boi.sm188dadu.top", "boi.10001slot.org", "nu7.sm188dadu.top", "nu7.10001slot.org", "poh.sm188dadu.top", "poh.10001slot.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Vidar
let malicious_urls = dynamic(["https://byz.sm188dadu.top/", "https://byz.10001slot.org/", "https://steamcommunity.com/profiles/76561198657426610", "https://2.28.26.204", "https://telegram.me/m1duus", "https://89.167.3.143", "https://boi.sm188dadu.top/", "https://boi.10001slot.org/", "https://nu7.sm188dadu.top/", "https://nu7.10001slot.org/", "https://poh.sm188dadu.top/", "https://kee.10001slot.org", "https://xdr.10001slot.org", "https://tip.10001slot.org", "https://kee.sm188dadu.top"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are 4 specific false positive scenarios for the ThreatFox: Vidar IOCs detection rule, including targeted filters and exclusions suitable for an enterprise environment:
Scenario: Antivirus Definition Updates via Scheduled Tasks
MsMpEng.exe for Defender or Cfsensservice.exe for CrowdStrike) and the Parent Process ID. Exclude alerts where the initiating process is a known AV service running under a scheduled task context (e.g., Task Scheduler parent).Scenario: Software Deployment via Configuration Management Tools
SYSTEM or a dedicated service account (e.g., DOMAIN\SCCM-Deploy) and the source IP belongs to the internal corporate subnet range.Scenario: Internal Security Scanning by EDR Agents