This hunt detects adversary activity involving the Vidar infostealer by monitoring for matches against a curated set of 24 Indicators of Compromise (IOCs) known to facilitate credential theft and data exfiltration. The SOC team should proactively hunt for these signals in Azure Sentinel because Vidar’s prevalence in modern supply chain attacks necessitates early identification of its specific network artifacts to prevent lateral movement and sensitive data loss before full-scale infection occurs.
Malware Family: Vidar Total IOCs: 24 IOC Types: domain, md5_hash, sha256_hash, sha1_hash, url
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| url | hxxps://jax.sm188dadu.top/ | botnet_cc | 2026-08-16 | 100% |
| domain | jax.sm188dadu.top | botnet_cc | 2026-08-16 | 100% |
| url | hxxps://jax[.]10001slot.org/ | botnet_cc | 2026-08-16 | 100% |
| domain | jax[.]10001slot.org | botnet_cc | 2026-08-16 | 100% |
| domain | prc.sm188daftar.com | botnet_cc | 2026-08-16 | 100% |
| url | hxxps://178[.]105[.]46[.]149 | botnet_cc | 2026-08-16 | 100% |
| url | hxxps://2[.]29[.]8[.]156 | botnet_cc | 2026-08-16 | 100% |
| domain | prc[.]10001toto.org | botnet_cc | 2026-08-16 | 100% |
| domain | joe.sm188dadu.top | botnet_cc | 2026-08-15 | 100% |
| url | hxxps://joe.sm188dadu.top/ | botnet_cc | 2026-08-15 | 100% |
| domain | joe[.]10001slot.org | botnet_cc | 2026-08-15 | 100% |
| md5_hash | f9c60eb51354ab07885428d7b868ade6 | payload | 2026-08-15 | 95% |
| sha256_hash | 63eedb85b370d3d55a6023987dc1ca36c49074b364804b3187aa9db9eac2dd33 | payload | 2026-08-15 | 95% |
| sha1_hash | 89dba32d78049d5650f10eb53173461a4969b673 | payload | 2026-08-15 | 95% |
| sha1_hash | fb837122ffb8b7041986db79fdd5e908d8ec38c8 | payload | 2026-08-15 | 95% |
| md5_hash | 4d4dad091692dc25b7ab60efab9fc5e3 | payload | 2026-08-15 | 95% |
| md5_hash | 9327108ce3c50647935244813d506f4d | payload | 2026-08-15 | 95% |
| sha256_hash | f2b7f869036f558eabe71d5f73820dd56a58269d3db1435f26daeeb687c49f9d | payload | 2026-08-15 | 95% |
| md5_hash | 25f8beb77d6bbfd007a326d24978827e | payload | 2026-08-15 | 95% |
| sha256_hash | 1d118a9482bb8f30bb53c18c8441d5aa8b21ee823206c630238edf0f99ec568e | payload | 2026-08-15 | 95% |
| sha1_hash | 01e3a1b3b3f89bf99c183aea978f17cf890eea01 | payload | 2026-08-15 | 95% |
| sha256_hash | 769c5186f40c16fa4e4871bf488301c01e89e3e94f1244f979e1b12b7f244ded | payload | 2026-08-15 | 95% |
| sha1_hash | 77f274a99d94bdab1709eff41f801bf893393130 | payload | 2026-08-15 | 95% |
| sha1_hash | 63a9e6a56ce653494116948cb043fd275b5ee5b5 | payload | 2026-08-15 | 95% |
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Vidar
let malicious_domains = dynamic(["jax.sm188dadu.top", "jax.10001slot.org", "prc.sm188daftar.com", "prc.10001toto.org", "joe.sm188dadu.top", "joe.10001slot.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Vidar
let malicious_urls = dynamic(["https://jax.sm188dadu.top/", "https://jax.10001slot.org/", "https://178.105.46.149", "https://2.29.8.156", "https://joe.sm188dadu.top/"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
// Hunt for files matching known malicious hashes
// Source: ThreatFox - Vidar
let malicious_hashes = dynamic(["f9c60eb51354ab07885428d7b868ade6", "63eedb85b370d3d55a6023987dc1ca36c49074b364804b3187aa9db9eac2dd33", "89dba32d78049d5650f10eb53173461a4969b673", "fb837122ffb8b7041986db79fdd5e908d8ec38c8", "4d4dad091692dc25b7ab60efab9fc5e3", "9327108ce3c50647935244813d506f4d", "f2b7f869036f558eabe71d5f73820dd56a58269d3db1435f26daeeb687c49f9d", "25f8beb77d6bbfd007a326d24978827e", "1d118a9482bb8f30bb53c18c8441d5aa8b21ee823206c630238edf0f99ec568e", "01e3a1b3b3f89bf99c183aea978f17cf890eea01", "769c5186f40c16fa4e4871bf488301c01e89e3e94f1244f979e1b12b7f244ded", "77f274a99d94bdab1709eff41f801bf893393130", "63a9e6a56ce653494116948cb043fd275b5ee5b5"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
DeviceFileEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios and corresponding exclusion strategies for the ThreatFox: Vidar IOCs detection rule in an enterprise environment:
Scenario: Automated Security Scanning by Endpoint Protection Agents
Process Name and Parent Process. Exclude alerts where the parent process is MsMpEng.exe (Microsoft Defender), FalconSensorService.exe (CrowdStrike), or CarbonBlack-Sensor.exe, provided the user context is SYSTEM or a dedicated service account.Scenario: Scheduled Software Updates via Package Management Tools
Process Path filter. Exclude alerts where the process path contains standard update directories such as \Program Files\Microsoft Configuration Manager\, and the user account is a known service account like DOMAIN\SCCM-Deploy-Svc.Scenario: Cloud Backup and Synchronization Services