This detection identifies adversary activity involving the Vidar infostealer by monitoring network and endpoint logs for specific Indicators of Compromise (IOCs) known to be used in active campaigns. SOC teams should proactively hunt for these signals within Azure Sentinel to rapidly detect early-stage data exfiltration attempts and prevent broader credential theft incidents before they escalate.
Malware Family: Vidar Total IOCs: 2 IOC Types: domain, url
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| domain | rmv[.]123ful.net | botnet_cc | 2026-08-27 | 100% |
| url | hxxps://rmv[.]123ful.net/ | botnet_cc | 2026-08-27 | 100% |
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Vidar
let malicious_domains = dynamic(["rmv.123ful.net"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Vidar
let malicious_urls = dynamic(["https://rmv.123ful.net/"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are the false positive scenarios and corresponding filters for the ThreatFox: Vidar IOCs detection rule:
Scenario 1: Endpoint Protection Policy Updates via Microsoft Defender for Endpoint
MsMpEng.exe (Microsoft Antimalware Service Executable) and restrict the detection to exclude traffic originating from Microsoft’s known update IP ranges (e.g., 13.107.x.x, 204.79.x.x).Scenario 2: Scheduled Third-Party Backup Jobs using Veeam or Commvault
VeeamAgent.exe and SimpanaDataAgent.exe.Scenario 3: Admin Deployment of Software via SCCM/Intune