This hunt detects adversary activity involving the Vidar infostealer by monitoring network and endpoint logs for matches against a curated set of 13 known indicators of compromise. Proactively hunting for these IOCs in Azure Sentinel is critical to identify early-stage infections that could lead to credential theft and lateral movement before they escalate into broader data breaches.
Malware Family: Vidar Total IOCs: 13 IOC Types: md5_hash, sha1_hash, sha256_hash
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| md5_hash | a8b6f506c3465cc8f015edfff552e7f8 | payload | 2026-08-22 | 95% |
| sha256_hash | 7c221128c38739c84f60a24c495aa2600ea152755be10de0637f2f38c948e087 | payload | 2026-08-22 | 95% |
| sha1_hash | 42b7294711767ee10032a4513365dc5133c3135f | payload | 2026-08-22 | 95% |
| md5_hash | 5dd22e75f4a2814af58c317fa2e2cd92 | payload | 2026-08-22 | 95% |
| sha1_hash | e4260dfd76bd97463a7c875b0764068c7ca26bee | payload | 2026-08-22 | 95% |
| md5_hash | 0344ea912263f13b49d9ad862a88cf4d | payload | 2026-08-22 | 95% |
| sha256_hash | 137760599d5ef9de1f6997006a148d0222e4ee442e900e31837fab6d26d0eb76 | payload | 2026-08-22 | 95% |
| sha1_hash | 23234d20c832f1ce025a3d311f59bb9b33618d20 | payload | 2026-08-22 | 95% |
| sha1_hash | 91c3431e51158aa800a452222a2404d7b82631ea | payload | 2026-08-22 | 95% |
| md5_hash | 16addb6524e5cf76f4114b0979f715ff | payload | 2026-08-22 | 95% |
| sha256_hash | 39298be200be86c3dd12bed11d76959423a33a2d74cb719e0abf76d4e9551b9c | payload | 2026-08-22 | 95% |
| md5_hash | 60f6b6954afed7de062f392a27ec910d | payload | 2026-08-22 | 95% |
| sha256_hash | 2d43d592630ad1e012da63ef7279f95dd4a8e94964e12ca2f996051875574fa6 | payload | 2026-08-22 | 95% |
// Hunt for files matching known malicious hashes
// Source: ThreatFox - Vidar
let malicious_hashes = dynamic(["a8b6f506c3465cc8f015edfff552e7f8", "7c221128c38739c84f60a24c495aa2600ea152755be10de0637f2f38c948e087", "42b7294711767ee10032a4513365dc5133c3135f", "5dd22e75f4a2814af58c317fa2e2cd92", "e4260dfd76bd97463a7c875b0764068c7ca26bee", "0344ea912263f13b49d9ad862a88cf4d", "137760599d5ef9de1f6997006a148d0222e4ee442e900e31837fab6d26d0eb76", "23234d20c832f1ce025a3d311f59bb9b33618d20", "91c3431e51158aa800a452222a2404d7b82631ea", "16addb6524e5cf76f4114b0979f715ff", "39298be200be86c3dd12bed11d76959423a33a2d74cb719e0abf76d4e9551b9c", "60f6b6954afed7de062f392a27ec910d", "2d43d592630ad1e012da63ef7279f95dd4a8e94964e12ca2f996051875574fa6"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
DeviceFileEvents | Ensure this data connector is enabled |
Here are the false positive scenarios and corresponding exclusions for the ThreatFox: Vidar IOCs detection rule:
Scenario: Legitimate Software Updates via Patch Management Tools
ProcessName matches known patch agents (ccmsetup.exe, IvantiAgentService) and the parent process is a scheduled task under the “System” account running during business hours (08:00–18:00).Scenario: Scheduled Antivirus or EDR Definition Updates
ParentProcessName is the EDR agent (e.g., CnsService.exe, SentinelOneAgent) and the event source is a scheduled job named “Definition Update” running on the local system account.Scenario: Admin-Driven Deployment of Internal Line-of-Business Applications