This hunt detects adversary activity involving the Vidar infostealer by monitoring for matches against a curated set of 30 known Indicators of Compromise (IOCs). Proactively hunting for these signals in Azure Sentinel is critical to identify early-stage infections and prevent data exfiltration before the malware establishes persistence or spreads laterally across the network.
Malware Family: Vidar Total IOCs: 30 IOC Types: ip:port, url, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 62[.]238[.]98[.]35:443 | botnet_cc | 2026-08-20 | 100% |
| ip:port | 62[.]238[.]106[.]96:443 | botnet_cc | 2026-08-20 | 100% |
| ip:port | 2[.]29[.]13[.]241:443 | botnet_cc | 2026-08-20 | 100% |
| ip:port | 2[.]29[.]7[.]186:443 | botnet_cc | 2026-08-20 | 100% |
| ip:port | 158[.]94[.]210[.]96:443 | botnet_cc | 2026-08-20 | 100% |
| domain | ryr[.]1131gg.org | botnet_cc | 2026-08-20 | 100% |
| domain | guc[.]1131gg.org | botnet_cc | 2026-08-20 | 100% |
| domain | ses.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | nhg.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | ges.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | kra.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | brr.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | sto.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | rex.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | bib.sm188daftar.mom | botnet_cc | 2026-08-20 | 100% |
| domain | guc.sm188dnsx.top | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://brr.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://sto.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://rex.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://bib.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://ses.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://nhg.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://ges.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://kra.sm188daftar.mom/ | botnet_cc | 2026-08-20 | 100% |
| url | hxxps://62[.]238[.]106[.]96/ | botnet_cc | 2026-08-20 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Vidar
let malicious_ips = dynamic(["158.94.210.96", "2.29.13.241", "62.238.106.96", "62.238.98.35", "2.29.7.186"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["158.94.210.96", "2.29.13.241", "62.238.106.96", "62.238.98.35", "2.29.7.186"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Vidar
let malicious_domains = dynamic(["ryr.1131gg.org", "guc.1131gg.org", "ses.sm188daftar.mom", "nhg.sm188daftar.mom", "ges.sm188daftar.mom", "kra.sm188daftar.mom", "brr.sm188daftar.mom", "sto.sm188daftar.mom", "rex.sm188daftar.mom", "bib.sm188daftar.mom", "guc.sm188dnsx.top"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Vidar
let malicious_urls = dynamic(["https://brr.sm188daftar.mom/", "https://sto.sm188daftar.mom/", "https://rex.sm188daftar.mom/", "https://bib.sm188daftar.mom/", "https://ses.sm188daftar.mom/", "https://nhg.sm188daftar.mom/", "https://ges.sm188daftar.mom/", "https://kra.sm188daftar.mom/", "https://62.238.106.96/", "https://2.29.13.241/", "https://2.29.7.186/", "https://158.94.210.96/", "https://ryr.1131gg.org/", "https://guc.1131gg.org/"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios and corresponding filtering strategies for the ThreatFox: Vidar IOCs detection rule in an enterprise environment:
Scenario: Software Deployment via Endpoint Management Tools
ccmsetup.exe, intuneagent.exe) and filter out events where the Parent Process is a trusted management service. Additionally, exclude specific file paths known to host these deployments, such as C:\Program Files\Microsoft Intune Agent\.Scenario: Scheduled Antivirus or EDR Scans
NT SERVICE\AntivirusEngine or DOMAIN\svc_scan) rather than an interactive user session.Scenario: Legacy Application Updates via Scheduled Tasks