← Back to SOC feed Coverage →

ThreatFox: XWorm IOCs

ioc-hunt HIGH ThreatFox
CommonSecurityLogDeviceNetworkEventsDnsEvents
iocthreatfoxwin-xworm
This detection content is auto-generated from open-source rule repositories and enriched with AI analysis. Always validate rules in a test environment before deploying to production Sentinel workspaces.
View original rule at ThreatFox →
Retrieved: 2026-03-19T03:46:59Z · Confidence: high

Hunt Hypothesis

Hunt package for 5 IOCs associated with XWorm

IOC Summary

Malware Family: XWorm Total IOCs: 5 IOC Types: ip:port, domain

TypeValueThreat TypeFirst SeenConfidence
domainayidhh-48261.portmap.hostbotnet_cc2026-03-19100%
domainaliowiasidaids-62178.portmap.hostbotnet_cc2026-03-19100%
domainsex4fun.duckdns.orgbotnet_cc2026-03-19100%
ip:port41[.]45[.]156[.]241:5505botnet_cc2026-03-18100%
ip:port154[.]219[.]104[.]140:7007botnet_cc2026-03-18100%

KQL: Ip Hunt

// Hunt for network connections to known malicious IPs
// Source: ThreatFox - XWorm
let malicious_ips = dynamic(["154.219.104.140", "41.45.156.241"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc

KQL: Ip Hunt Device

// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["154.219.104.140", "41.45.156.241"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - XWorm
let malicious_domains = dynamic(["ayidhh-48261.portmap.host", "aliowiasidaids-62178.portmap.host", "sex4fun.duckdns.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DeviceNetworkEventsEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

Original source: https://threatfox.abuse.ch/browse/malware/win.xworm/