← Back to SOC feed Coverage →

Top 10 domains sending Bulk email

kql MEDIUM Azure-Sentinel
T1566
EmailEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-17T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be using compromised domains to send bulk emails as part of a phishing or spam campaign, leveraging the domain’s reputation to bypass email filters. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate potential credential theft or malware distribution vectors.

KQL Query

//This query visualises total inbound emails which has any Bulk complaint level. It is summarizing the data by the various Bulk Complaint levels and SenderFromDomain of the email sender. It provides insights how many messages are detected with each Bulk Complaint level for each sender domain.
EmailEvents
| where EmailDirection == "Inbound" and BulkComplaintLevel !=""
| where Timestamp > ago(30d) // last 30 days by default, replace 30d with the desired period
| summarize count() by BulkComplaintLevel, SenderFromDomain
| sort by count_ desc
| project SenderFromDomain,BulkComplaintLevel,Emails=count_
| take 10

Analytic Rule Definition

id: fc3e5da4-9a8d-4f2f-b714-7118bc00b5d8
name: Top 10 domains sending Bulk email
description: |
  This query visualises total inbound emails which has any Bulk complaint level.
description-detailed: |
  This query visualises total inbound emails which has any Bulk complaint level. It is summarizing the data by the various Bulk Complaint levels and SenderFromDomain of the email sender. It provides insights how many messages are detected with each Bulk Complaint level for each sender domain in Microsoft Defender for Office 365.
  Taken from the the Microsoft Defender for Office 365 Detections and Insights - Microsoft Sentinel workbook.
  https://techcommunity.microsoft.com/blog/microsoftdefenderforoffice365blog/part-2-build-custom-email-security-reports-and-dashboards-with-workbooks-in-micr/4411303
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - EmailEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  //This query visualises total inbound emails which has any Bulk complaint level. It is summarizing the data by the various Bulk Complaint levels and SenderFromDomain of the email sender. It provides insights how many messages are detected with each Bulk Complaint level for each sender domain.
  EmailEvents
  | where EmailDirection == "Inbound" and BulkComplaintLevel !=""
  | where Timestamp > ago(30d) // last 30 days by default, replace 30d with the desired period
  | summarize count() by BulkComplaintLevel, SenderFromDomain
  | sort by count_ desc
  | project SenderFromDomain,BulkComplaintLevel,Emails=count_
  | take 10
version: 1.0.0

Required Data Sources

Sentinel TableNotes
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Spam/Bulk Detection Top10 Domains.yaml