← Back to SOC feed Coverage →

Top 10 Users clicking on malicious URLs in Teams

kql MEDIUM Azure-Sentinel
T1566
UrlClickEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-12T23:00:00Z · Confidence: medium

Hunt Hypothesis

Top 10 Users clicking on malicious URLs in Teams indicates potential phishing or malware delivery attempts by adversaries leveraging trusted communication channels. SOC teams should proactively hunt for this behavior to identify and mitigate early-stage compromise attempts in their Azure Sentinel environment.

KQL Query

//Top 10 Users clicking on malicious URLs in Teams
UrlClickEvents 
| where Workload =="Teams" and ThreatTypes in ("Phish","Malware") 
| summarize Blocked = countif(ActionType =="ClickBlocked"), Allowed = countif(ActionType =="ClickAllowed"), PendingVerdict = countif(ActionType =="UrlScanInProgress"), Error = countif(ActionType =="UrlErrorPage"), ClickedThrough = countif(IsClickedThrough)by AccountUpn
| top 10 by Blocked desc

Analytic Rule Definition

id: 2186afac-1cde-441d-9825-0dbfd5f59d05
name: Top 10 Users clicking on malicious URLs in Teams
description: |
  This query visualizes Top 10 Users clicking on malicious Phish or Malware URLs in Teams.
description-detailed: |
  This query visualizes Top 10 Users clicking on malicious Phish or Malware URLs in Teams.
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - UrlClickEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  //Top 10 Users clicking on malicious URLs in Teams
  UrlClickEvents 
  | where Workload =="Teams" and ThreatTypes in ("Phish","Malware") 
  | summarize Blocked = countif(ActionType =="ClickBlocked"), Allowed = countif(ActionType =="ClickAllowed"), PendingVerdict = countif(ActionType =="UrlScanInProgress"), Error = countif(ActionType =="UrlErrorPage"), ClickedThrough = countif(IsClickedThrough)by AccountUpn
  | top 10 by Blocked desc
version: 1.0.0

Required Data Sources

Sentinel TableNotes
UrlClickEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Microsoft Teams protection/Top 10 Users clicking on malicious URLs in Teams.yaml