← Back to SOC feed Coverage →

Top policies performing admin overrides

kql MEDIUM Azure-Sentinel
T1566
EmailEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-12T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may use admin overrides to bypass policy restrictions and gain unauthorized access or control within the environment. SOC teams should proactively hunt for this behavior to identify potential privilege escalation or bypass attempts that could lead to persistent or lateral movement.

KQL Query

EmailEvents  
| where OrgLevelPolicy!="" and OrgLevelAction == "Allow"  //"Block"
| extend OrgPolicy = split(OrgLevelPolicy, "(", 0)
| summarize count() by tostring(OrgPolicy)
| render piechart

Analytic Rule Definition

id: c73ae295-d120-4f79-aaed-de005f766ad2
name: Top policies performing admin overrides
description: |
  This query helps in reviewing top policies for admin overrides (Allow/Block)
description-detailed: |
  This query helps in reviewing top policies for admin defined detection overrides (Allow/Block)in Defender for Office 365
  Reference - https://learn.microsoft.com/en-us/defender-office-365/step-by-step-guides/understand-overrides-in-email-entity and https://techcommunity.microsoft.com/t5/microsoft-defender-for-office/email-protection-basics-in-microsoft-365-part-five-mastering/ba-p/4139035
requiredDataConnectors:
  - connectorId: MicrosoftThreatProtection
    dataTypes:
      - EmailEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  EmailEvents  
  | where OrgLevelPolicy!="" and OrgLevelAction == "Allow"  //"Block"
  | extend OrgPolicy = split(OrgLevelPolicy, "(", 0)
  | summarize count() by tostring(OrgPolicy)
  | render piechart
version: 1.0.0

Required Data Sources

Sentinel TableNotes
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Overrides/Top policies performing admin overrides.yaml