← Back to SOC feed Coverage →

Top targeted users

kql MEDIUM Azure-Sentinel
T1566
EmailEvents
huntingmicrosoftofficialphishing
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-19T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may target specific users with malware or phishing emails to gain initial access or exfiltrate data. Proactively hunting for these targeted users in Azure Sentinel can help identify potential compromise early and prevent further lateral movement or data loss.

KQL Query

EmailEvents 
| where Timestamp > ago(30d) 
| where ThreatTypes has "Malware" or ThreatTypes has "Phish" 
| summarize count() by RecipientEmailAddress 
| sort by count_

Analytic Rule Definition

id: a1664330-810a-473b-b354-acbaa751a294
name: Top targeted users
description: |
  This query helps reviewing top targeted users with malware or phishing emails in an organization in last 30 days
description-detailed: |
  This query helps reviewing top targeted users with malware or phishing emails in an organization in last 30 days using Defender for Office 365 data.
requiredDataConnectors:
  - connectorId: MicrosoftThreatProtection
    dataTypes:
      - EmailEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  EmailEvents 
  | where Timestamp > ago(30d) 
  | where ThreatTypes has "Malware" or ThreatTypes has "Phish" 
  | summarize count() by RecipientEmailAddress 
  | sort by count_
version: 1.0.0

Required Data Sources

Sentinel TableNotes
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Top Attacks/Top targeted users.yaml