← Back to SOC feed Coverage →

URL click on ZAP email

kql MEDIUM Azure-Sentinel
T1566
AlertEvidenceUrlClickEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-19T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be using Zerohour auto purge to obfuscate command and control communications by embedding malicious URLs in emails that are clicked and purged quickly. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential exfiltration or C2 activity that evades traditional detection methods.

KQL Query

AlertInfo
| where Title contains "Email messages containing malicious URL removed after delivery" and Timestamp > ago (7d)
| join kind=inner (AlertEvidence| where EntityType == "MailMessage") on AlertId 
| join UrlClickEvents on NetworkMessageId

Analytic Rule Definition

id: efe27064-6d35-4720-b7f5-e0326695613d
name: URL click on ZAP email
description: |
  In this query, we are looking for Url clicks on emails which get actioned by Zerohour auto purge
description-detailed: |
  In this query, we are looking for Url clicks on emails which get actioned by Zerohour auto purge (ZAP) in Defender for Office 365.
  Reference - https://learn.microsoft.com/en-us/defender-office-365/zero-hour-auto-purge
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
   - UrlClickEvents
   - Alertinfo
   - AlertEvidence
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  AlertInfo
  | where Title contains "Email messages containing malicious URL removed after delivery" and Timestamp > ago (7d)
  | join kind=inner (AlertEvidence| where EntityType == "MailMessage") on AlertId 
  | join UrlClickEvents on NetworkMessageId
version: 1.0.0 

Required Data Sources

Sentinel TableNotes
AlertEvidenceEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/URL Click/URL click on ZAP Email.yaml