← Back to SOC feed Coverage →

URL Detection

kql MEDIUM Azure-Sentinel
DeviceNetworkEvents
backdoorhuntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-09T23:00:01Z · Confidence: medium

Hunt Hypothesis

The URL Detection rule identifies potential adversary communication to suspicious URLs, which may indicate command and control or data exfiltration activities. SOC teams should proactively hunt for this behavior in Azure Sentinel to detect early-stage threats and prevent lateral movement or data compromise.

KQL Query

let partialRemoteUrlToDetect = "microsoft.com"; // Change this to a URL you'd like to find machines connecting to
DeviceNetworkEvents  
| where Timestamp > ago(7d)
and RemoteUrl has partialRemoteUrlToDetect // Can be changed to "contains" operator as explained above
| project Timestamp, DeviceName, DeviceId, ReportId
| top 100 by Timestamp desc

Analytic Rule Definition

id: be220c78-843b-43c5-b638-dc9d10100c75
name: URL Detection
description: |
  This query finds network communication to specific URL.
  Please note that in line #7 it filters RemoteUrl using has operator, which looks for a "whole term" and runs faster.
  Example: RemoteUrl has "microsoft" matches "www.microsoft.com" but not "microsoftonline.com".
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceNetworkEvents
query: |
  let partialRemoteUrlToDetect = "microsoft.com"; // Change this to a URL you'd like to find machines connecting to
  DeviceNetworkEvents  
  | where Timestamp > ago(7d)
  and RemoteUrl has partialRemoteUrlToDetect // Can be changed to "contains" operator as explained above
  | project Timestamp, DeviceName, DeviceId, ReportId
  | top 100 by Timestamp desc

Required Data Sources

Sentinel TableNotes
DeviceNetworkEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Discovery/URL Detection.yaml