This hunt targets potential web-based initial access or command-and-control channels by identifying traffic to a specific cluster of 14 malicious URLs associated with the IP 31.56.209.210. Proactively hunting for these indicators in Azure Sentinel allows the SOC team to detect compromised endpoints or lateral movement attempts before the adversary establishes a persistent foothold or executes further post-compromise actions.
Threat: 31-56-209-210 Total URLs: 14 Active URLs: 11
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://31.56.209.210/a/b/agent_armv5 | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/netlogd_mipsel | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/netlogd_armv5 | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/agent_aarch64 | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/agent_armv7hf | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/netlogd_aarch64 | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/netlogd_armv7hf | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/agent_mipsbe | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/netlogd_mipsbe | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/netlogd_x86_64 | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/b/agent_mipsel | online | malware_download | 2026-09-02 |
hxxp://31.56.209.210/multi/wget.sh | offline | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/wget.sh | offline | malware_download | 2026-09-02 |
hxxp://31.56.209.210/a/recon.sh | offline | malware_download | 2026-09-02 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 31-56-209-210
let malicious_domains = dynamic(["31.56.209.210"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["31.56.209.210"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
curl or wget in a Linux cron job or Windows Task Scheduler) that pings a specific external endpoint to verify network connectivity before initiating large data transfers to a cloud storage bucket.
cron, systemd, or Task Scheduler and the destination URL matches the specific backup verification endpoint.Postman, curl, or python-requests.