This hunt targets potential compromise vectors where endpoints interact with known 32-bit malicious URLs, indicating the execution of legacy or specific architecture-targeted malware payloads. Proactively hunting for these indicators in Azure Sentinel allows the SOC to identify and isolate affected assets before they can establish persistence or lateral movement within the environment.
Threat: 32-bit Total URLs: 42 Active URLs: 36
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://222.142.242.76:51781/i | online | malware_download | 2026-09-16 |
hxxp://222.142.242.76:51781/bin.sh | online | malware_download | 2026-09-16 |
hxxp://182.123.192.25:51135/i | online | malware_download | 2026-09-16 |
hxxp://61.53.148.53:39023/i | online | malware_download | 2026-09-16 |
hxxp://115.55.234.102:53882/bin.sh | online | malware_download | 2026-09-16 |
hxxp://61.53.148.53:39023/bin.sh | online | malware_download | 2026-09-16 |
hxxp://89.189.181.54:60243/bin.sh | online | malware_download | 2026-09-16 |
hxxp://60.23.232.20:51644/i | online | malware_download | 2026-09-16 |
hxxp://171.36.18.157:35519/i | online | malware_download | 2026-09-16 |
hxxp://125.46.198.87:41297/i | online | malware_download | 2026-09-16 |
hxxp://216.126.86.6:57863/i | online | malware_download | 2026-09-16 |
hxxp://125.46.198.87:41297/bin.sh | online | malware_download | 2026-09-16 |
hxxp://124.158.191.121:53328/i | online | malware_download | 2026-09-16 |
hxxp://216.126.86.6:57863/bin.sh | online | malware_download | 2026-09-16 |
hxxp://78.85.226.138:46350/i | online | malware_download | 2026-09-16 |
hxxp://78.85.226.138:46350/bin.sh | online | malware_download | 2026-09-16 |
hxxp://115.48.160.255:52757/bin.sh | online | malware_download | 2026-09-16 |
hxxp://27.207.224.71:51240/i | offline | malware_download | 2026-09-16 |
hxxp://123.10.203.156:35020/i | online | malware_download | 2026-09-16 |
hxxp://121.224.220.11:54375/i | offline | malware_download | 2026-09-16 |
hxxp://120.28.215.200:38097/i | offline | malware_download | 2026-09-16 |
hxxp://218.58.236.22:48839/i | online | malware_download | 2026-09-16 |
hxxp://42.55.5.239:44015/bin.sh | online | malware_download | 2026-09-16 |
hxxp://42.226.64.10:47116/i | online | malware_download | 2026-09-16 |
hxxp://120.28.215.200:38097/bin.sh | online | malware_download | 2026-09-16 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 32-bit
let malicious_domains = dynamic(["42.226.64.10", "124.158.191.121", "78.85.226.138", "115.55.234.102", "105.184.131.46", "42.6.143.173", "216.126.86.6", "182.123.192.25", "123.10.203.156", "120.28.215.200", "180.110.39.190", "113.237.37.213", "115.48.160.255", "89.189.181.54", "60.23.232.20", "42.55.5.239", "171.36.18.157", "222.142.242.76", "218.58.236.22", "125.46.198.87", "175.43.154.55", "61.53.148.53"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["42.226.64.10", "124.158.191.121", "78.85.226.138", "115.55.234.102", "105.184.131.46", "42.6.143.173", "216.126.86.6", "182.123.192.25", "123.10.203.156", "120.28.215.200", "180.110.39.190", "113.237.37.213", "115.48.160.255", "89.189.181.54", "60.23.232.20", "42.55.5.239", "171.36.18.157", "222.142.242.76", "218.58.236.22", "125.46.198.87", "175.43.154.55", "61.53.148.53"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
*.legacy-app-update.com) and exclude these specific domains from the URLhaus 32-bit threat feed, or whitelist the specific 32-bit process names (e.g., legacy_app.exe) initiating the connection.curl or wget to push logs to a local staging server or a specific 32-bit compatible API gateway that shares an IP/domain with a known malicious URLhaus entry.
powershell.exe or cmd.exe) and the script path (e.g., C:\Scripts\log_cleanup.ps1). Exclude connections where the parent process is a known internal scripting engine and the destination URL matches the internal staging server’s domain.