This hypothesis targets adversaries leveraging 32-bit malicious URLs to execute payloads or establish command-and-control channels, often exploiting legacy architecture vulnerabilities or specific binary compatibility. Proactively hunting for these indicators in Azure Sentinel allows the SOC to identify compromised endpoints or suspicious web traffic before attackers can fully establish persistence or exfiltrate data.
Threat: 32-bit Total URLs: 25 Active URLs: 16
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://112.230.155.183:39618/bin.sh | online | malware_download | 2026-09-03 |
hxxp://173.92.213.119:52110/bin.sh | online | malware_download | 2026-09-03 |
hxxp://182.126.93.33:37461/i | online | malware_download | 2026-09-03 |
hxxp://119.179.254.3:36720/i | online | malware_download | 2026-09-03 |
hxxp://119.179.254.3:36720/bin.sh | online | malware_download | 2026-09-03 |
hxxp://122.241.130.212:45870/i | online | malware_download | 2026-09-03 |
hxxp://66.212.173.225:46177/i | offline | malware_download | 2026-09-03 |
hxxp://115.57.80.149:55734/i | online | malware_download | 2026-09-03 |
hxxp://66.212.173.225:46177/bin.sh | online | malware_download | 2026-09-03 |
hxxp://182.112.7.122:58694/i | online | malware_download | 2026-09-03 |
hxxp://122.241.130.212:45870/bin.sh | offline | malware_download | 2026-09-03 |
hxxp://196.189.69.192:57870/i | online | malware_download | 2026-09-03 |
hxxp://196.189.69.192:57870/bin.sh | offline | malware_download | 2026-09-03 |
hxxp://42.59.71.140:35247/i | online | malware_download | 2026-09-03 |
hxxp://179.108.90.55:44298/i | online | malware_download | 2026-09-03 |
hxxp://42.59.71.140:35247/bin.sh | online | malware_download | 2026-09-03 |
hxxp://179.108.90.55:44298/bin.sh | online | malware_download | 2026-09-03 |
hxxp://105.225.48.83:57349/i | offline | malware_download | 2026-09-03 |
hxxp://119.117.177.176:57366/bin.sh | offline | malware_download | 2026-09-03 |
hxxp://105.225.46.244:56367/i | offline | malware_download | 2026-09-03 |
hxxp://125.41.75.42:36742/i | offline | malware_download | 2026-09-03 |
hxxp://39.52.44.227:52719/i | offline | malware_download | 2026-09-03 |
hxxp://39.52.44.227:52719/bin.sh | offline | malware_download | 2026-09-03 |
hxxp://125.160.139.10:40058/i | online | malware_download | 2026-09-03 |
hxxp://209.81.111.104:55587/i | online | malware_download | 2026-09-03 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 32-bit
let malicious_domains = dynamic(["196.189.69.192", "66.212.173.225", "115.57.80.149", "42.59.71.140", "125.160.139.10", "119.179.254.3", "112.230.155.183", "173.92.213.119", "182.112.7.122", "179.108.90.55", "209.81.111.104", "122.241.130.212", "182.126.93.33"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["196.189.69.192", "66.212.173.225", "115.57.80.149", "42.59.71.140", "125.160.139.10", "119.179.254.3", "112.230.155.183", "173.92.213.119", "182.112.7.122", "179.108.90.55", "209.81.111.104", "122.241.130.212", "182.126.93.33"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Selenium, Playwright, Cypress) or specific QA user groups. Alternatively, exclude URLs containing /test/, /staging/, or /compat/ path segments.chrome.exe, firefox.exe, msedge.exe) or specific plugin host processes (javaw.exe, plugin-container.exe). Check if the URL ends with common manifest extensions like .json, .xml, or .plist.VeeamSvc.exe, commvault.exe, onedrive.exe). Filter out URLs containing /api/, /license/, or /sync/ path segments.