This detection identifies adversary activity involving access to known 32-bit malicious URLs that may indicate initial compromise or command-and-control communication via legacy endpoints. Proactive hunting for these specific indicators in Azure Sentinel is critical to uncover potential threats targeting older architectures that often lack modern security controls, thereby reducing the risk of undetected lateral movement or data exfiltration.
Threat: 32-bit Total URLs: 47 Active URLs: 35
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://119.114.63.205:38557/i | online | malware_download | 2026-08-20 |
hxxp://123.9.223.160:52129/i | online | malware_download | 2026-08-20 |
hxxp://112.248.174.58:54368/bin.sh | online | malware_download | 2026-08-20 |
hxxp://223.151.74.149:48587/bin.sh | offline | malware_download | 2026-08-20 |
hxxp://119.114.63.205:38557/bin.sh | online | malware_download | 2026-08-20 |
hxxp://115.55.52.24:36106/i | online | malware_download | 2026-08-20 |
hxxp://182.123.162.14:46510/i | online | malware_download | 2026-08-20 |
hxxp://123.9.223.160:52129/bin.sh | online | malware_download | 2026-08-20 |
hxxp://115.55.52.24:36106/bin.sh | online | malware_download | 2026-08-20 |
hxxp://115.61.118.232:57819/bin.sh | online | malware_download | 2026-08-20 |
hxxp://182.123.162.14:46510/bin.sh | online | malware_download | 2026-08-20 |
hxxp://61.54.253.22:60163/i | online | malware_download | 2026-08-20 |
hxxp://182.121.43.33:42422/i | online | malware_download | 2026-08-20 |
hxxp://123.9.195.116:34313/i | offline | malware_download | 2026-08-20 |
hxxp://123.190.17.0:42140/bin.sh | online | malware_download | 2026-08-20 |
hxxp://182.121.43.33:42422/bin.sh | online | malware_download | 2026-08-20 |
hxxp://61.54.253.22:60163/bin.sh | offline | malware_download | 2026-08-20 |
hxxp://46.236.65.235:41753/i | online | malware_download | 2026-08-20 |
hxxp://140.237.7.157:41787/i | online | malware_download | 2026-08-20 |
hxxp://42.230.209.22:37617/i | online | malware_download | 2026-08-20 |
hxxp://42.230.209.22:37617/bin.sh | online | malware_download | 2026-08-20 |
hxxp://112.248.174.58:54368/i | online | malware_download | 2026-08-20 |
hxxp://27.207.216.59:45025/i | online | malware_download | 2026-08-20 |
hxxp://42.56.136.70:46446/i | online | malware_download | 2026-08-20 |
hxxp://113.236.118.216:50033/i | online | malware_download | 2026-08-20 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 32-bit
let malicious_domains = dynamic(["115.61.118.232", "42.230.209.22", "42.225.241.153", "46.236.65.235", "112.248.174.58", "182.130.209.58", "123.9.223.160", "182.121.43.33", "42.56.136.70", "115.55.52.24", "61.54.253.22", "115.50.254.53", "222.137.105.216", "113.236.118.216", "27.207.216.59", "119.114.63.205", "140.237.7.157", "116.2.50.30", "123.190.17.0", "182.123.162.14"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["115.61.118.232", "42.230.209.22", "42.225.241.153", "46.236.65.235", "112.248.174.58", "182.130.209.58", "123.9.223.160", "182.121.43.33", "42.56.136.70", "115.55.52.24", "61.54.253.22", "115.50.254.53", "222.137.105.216", "113.236.118.216", "27.207.216.59", "119.114.63.205", "140.237.7.157", "116.2.50.30", "123.190.17.0", "182.123.162.14"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios and corresponding filters for the URLhaus: 32-bit Malicious URLs detection rule in an enterprise environment:
Legacy Point-of-Sale (POS) System Updates
Microsoft Update service or proprietary vendor agents (like NCR or Square), which may connect to URLs flagged as “potentially malicious” due to their age or mixed content, despite being trusted internal endpoints.*.squareup.com, *.ncl.com) and restrict the detection scope to exclude traffic originating from the “POS-DMZ” network segment or specific MAC address ranges of terminal devices.32-bit Office Add-in Telemetry
WINWORD.EXE, EXCEL.EXE, and ACROPDF.EXE (specifically the 32-bit builds) when accessing Microsoft-owned domains (*.microsoft.com, *.office.com) or known Adobe telemetry endpoints.Scheduled Antivirus Definition Refreshes