← Back to SOC feed Coverage →

URLhaus: 32-bit Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-05-22T11:00:00Z · Confidence: medium

Hunt Hypothesis

The hypothesis is that the detected URLs are likely used by adversaries to deliver 32-bit malware, which may bypass modern endpoint protections. SOC teams should proactively hunt for these URLs in Azure Sentinel to identify and mitigate potential compromise of 32-bit systems that may have been overlooked by traditional detection methods.

IOC Summary

Threat: 32-bit Total URLs: 18 Active URLs: 17

URLStatusThreatDate Added
hxxp://42.239.14.102:42616/ionlinemalware_download2026-05-22
hxxp://182.121.215.209:49571/ionlinemalware_download2026-05-22
hxxp://125.41.141.71:40774/ionlinemalware_download2026-05-22
hxxp://103.171.168.74:36014/ionlinemalware_download2026-05-22
hxxp://103.171.168.74:36014/bin.shonlinemalware_download2026-05-22
hxxp://113.230.80.56:45482/ionlinemalware_download2026-05-22
hxxp://125.41.141.71:40774/bin.shonlinemalware_download2026-05-22
hxxp://182.127.35.64:49342/ionlinemalware_download2026-05-22
hxxp://182.126.81.234:51687/bin.shonlinemalware_download2026-05-22
hxxp://182.127.35.64:49342/bin.shonlinemalware_download2026-05-22
hxxp://59.97.248.51:49747/bin.shonlinemalware_download2026-05-22
hxxp://110.39.249.140:53182/ionlinemalware_download2026-05-22
hxxp://218.91.141.211:55109/bin.shonlinemalware_download2026-05-22
hxxp://39.74.106.57:48231/ionlinemalware_download2026-05-22
hxxp://123.188.88.173:50099/bin.shonlinemalware_download2026-05-22
hxxp://182.112.231.171:53301/ionlinemalware_download2026-05-22
hxxp://115.48.151.181:56013/ionlinemalware_download2026-05-22
hxxp://115.48.151.181:56013/bin.shofflinemalware_download2026-05-22

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 32-bit
let malicious_domains = dynamic(["123.188.88.173", "182.126.81.234", "115.48.151.181", "182.121.215.209", "125.41.141.71", "39.74.106.57", "182.127.35.64", "42.239.14.102", "59.97.248.51", "110.39.249.140", "182.112.231.171", "103.171.168.74", "218.91.141.211", "113.230.80.56"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["123.188.88.173", "182.126.81.234", "115.48.151.181", "182.121.215.209", "125.41.141.71", "39.74.106.57", "182.127.35.64", "42.239.14.102", "59.97.248.51", "110.39.249.140", "182.112.231.171", "103.171.168.74", "218.91.141.211", "113.230.80.56"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/