This detection identifies adversary behavior involving the execution of 32-bit malware through known malicious URLs, which often indicates initial access or command-and-control activity targeting legacy systems. A SOC team should proactively hunt for these indicators in Azure Sentinel to rapidly isolate compromised endpoints and prevent lateral movement before attackers can establish persistence within the network.
Threat: 32-bit Total URLs: 46 Active URLs: 38
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://182.116.20.77:59128/bin.sh | online | malware_download | 2026-08-21 |
hxxp://123.132.158.53:41696/bin.sh | online | malware_download | 2026-08-21 |
hxxp://113.231.127.198:37040/i | online | malware_download | 2026-08-21 |
hxxp://179.108.90.55:37440/i | online | malware_download | 2026-08-21 |
hxxp://182.120.163.131:49762/i | online | malware_download | 2026-08-21 |
hxxp://123.8.30.116:41163/i | online | malware_download | 2026-08-21 |
hxxp://179.108.90.55:37440/bin.sh | online | malware_download | 2026-08-21 |
hxxp://123.8.30.116:41163/bin.sh | online | malware_download | 2026-08-21 |
hxxp://112.248.60.89:60712/i | online | malware_download | 2026-08-21 |
hxxp://85.15.117.156:37936/i | online | malware_download | 2026-08-21 |
hxxp://222.138.117.213:54917/i | online | malware_download | 2026-08-21 |
hxxp://85.15.117.156:37936/bin.sh | online | malware_download | 2026-08-21 |
hxxp://42.177.103.199:46495/i | online | malware_download | 2026-08-21 |
hxxp://42.177.103.199:46495/bin.sh | online | malware_download | 2026-08-21 |
hxxp://220.192.234.145:55381/i | online | malware_download | 2026-08-21 |
hxxp://220.192.234.145:55381/bin.sh | online | malware_download | 2026-08-21 |
hxxp://182.116.51.119:37449/bin.sh | online | malware_download | 2026-08-21 |
hxxp://182.116.51.119:37449/i | online | malware_download | 2026-08-21 |
hxxp://175.147.243.79:60816/i | online | malware_download | 2026-08-21 |
hxxp://175.173.60.37:49335/i | online | malware_download | 2026-08-21 |
hxxp://124.131.166.85:34514/i | online | malware_download | 2026-08-21 |
hxxp://124.131.166.85:34514/bin.sh | online | malware_download | 2026-08-21 |
hxxp://113.221.25.94:37532/bin.sh | offline | malware_download | 2026-08-21 |
hxxp://115.49.64.122:48159/i | online | malware_download | 2026-08-21 |
hxxp://125.112.59.91:60395/i | offline | malware_download | 2026-08-21 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 32-bit
let malicious_domains = dynamic(["61.52.158.83", "222.138.117.213", "31.4.254.241", "42.177.103.199", "115.49.64.122", "123.8.30.116", "182.116.51.119", "182.116.20.77", "85.15.117.156", "175.173.60.37", "175.147.243.79", "117.26.82.102", "113.231.127.198", "220.192.234.145", "61.137.251.126", "124.131.166.85", "179.108.90.55", "182.120.163.131", "39.61.46.143", "123.132.158.53", "112.248.60.89"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["61.52.158.83", "222.138.117.213", "31.4.254.241", "42.177.103.199", "115.49.64.122", "123.8.30.116", "182.116.51.119", "182.116.20.77", "85.15.117.156", "175.173.60.37", "175.147.243.79", "117.26.82.102", "113.231.127.198", "220.192.234.145", "61.137.251.126", "124.131.166.85", "179.108.90.55", "182.120.163.131", "39.61.46.143", "123.132.158.53", "112.248.60.89"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Scenario: Legacy 32-bit Business Intelligence Reporting Tools accessing external data feeds.
DOMAIN\SSRS_Service) and whitelist the known external API endpoints used by the reporting suite in the detection logic.Scenario: Scheduled 32-bit Anti-Virus Definition Updates via Cloud Repositories.
DOMAIN\AV_Update_Svc) during defined maintenance windows (e.g., 02:00–04:00 UTC) and whitelist the vendor’s primary update domain (e.g., updates.symantec.com).Scenario: Automated 32-bit Backup Agents connecting to Cloud Storage Gateways.