This hunt targets the execution of 32-bit malicious binaries or payloads via known URLhaus URLs, indicating an adversary leveraging legacy architecture to bypass modern 64-bit defenses or exploit specific application vulnerabilities. Proactively hunting for these indicators in Azure Sentinel allows the SOC to identify compromised endpoints or web traffic patterns early, reducing the dwell time of threats that may evade standard signature-based detections.
Threat: 32-bit Total URLs: 64 Active URLs: 51
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://119.184.4.100:48083/i | online | malware_download | 2026-09-06 |
hxxp://38.196.84.42:40091/i | online | malware_download | 2026-09-06 |
hxxp://183.150.79.222:42629/i | online | malware_download | 2026-09-06 |
hxxp://119.184.4.100:48083/bin.sh | online | malware_download | 2026-09-06 |
hxxp://182.112.13.124:56784/i | online | malware_download | 2026-09-06 |
hxxp://38.196.84.42:40091/bin.sh | online | malware_download | 2026-09-06 |
hxxp://182.112.13.124:56784/bin.sh | online | malware_download | 2026-09-06 |
hxxp://94.244.36.34:42903/i | online | malware_download | 2026-09-06 |
hxxp://112.198.238.30:44431/i | online | malware_download | 2026-09-06 |
hxxp://110.136.98.236:48232/i | online | malware_download | 2026-09-06 |
hxxp://106.1.9.225:50153/bin.sh | online | malware_download | 2026-09-06 |
hxxp://112.198.238.30:44431/bin.sh | online | malware_download | 2026-09-06 |
hxxp://103.226.187.112:60437/i | online | malware_download | 2026-09-06 |
hxxp://103.226.187.112:60437/bin.sh | online | malware_download | 2026-09-06 |
hxxp://115.55.194.73:43155/i | online | malware_download | 2026-09-06 |
hxxp://115.58.86.52:34597/i | offline | malware_download | 2026-09-06 |
hxxp://61.137.247.139:38521/i | online | malware_download | 2026-09-06 |
hxxp://115.58.86.52:34597/bin.sh | online | malware_download | 2026-09-06 |
hxxp://61.137.247.139:38521/bin.sh | online | malware_download | 2026-09-06 |
hxxp://115.55.194.73:43155/bin.sh | online | malware_download | 2026-09-06 |
hxxp://125.43.226.173:40813/i | online | malware_download | 2026-09-06 |
hxxp://42.6.196.39:60329/i | online | malware_download | 2026-09-06 |
hxxp://42.6.196.39:60329/bin.sh | online | malware_download | 2026-09-06 |
hxxp://105.184.69.210:60923/i | online | malware_download | 2026-09-06 |
hxxp://42.52.204.46:54830/i | online | malware_download | 2026-09-06 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: 32-bit
let malicious_domains = dynamic(["94.244.36.34", "119.184.4.100", "105.184.69.210", "210.208.116.107", "210.208.110.221", "103.226.187.112", "110.136.98.236", "42.52.204.46", "183.150.79.222", "42.6.196.39", "115.55.194.73", "182.112.13.124", "112.198.238.30", "38.196.84.42", "125.43.226.173", "106.1.9.225", "61.137.247.139", "115.58.86.52"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["94.244.36.34", "119.184.4.100", "105.184.69.210", "210.208.116.107", "210.208.110.221", "103.226.187.112", "110.136.98.236", "42.52.204.46", "183.150.79.222", "42.6.196.39", "115.55.194.73", "182.112.13.124", "112.198.238.30", "38.196.84.42", "125.43.226.173", "106.1.9.225", "61.137.247.139", "115.58.86.52"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Legacy 32-bit Application Updates:
/update/, /patch/, /download/) for specific vendor domains (e.g., adobe.com, java.com) if the User-Agent string contains 32-bit or Win32 and the process is a known updater service (e.g., AdobeUpdateService.exe, java.exe).Scheduled 32-bit Agent Telemetry:
falconctl.exe, zscaler.exe) and ensure the process is signed by the vendor. Exclude URLs where the query string contains version=32 or arch=x86 and the destination port is 443 with a valid TLS certificate.Internal 32-bit Web Service Deployment: