← Back to SOC feed Coverage →

URLhaus: ACRStealer Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
infostealeriocurlhaus
This detection content is auto-generated from open-source rule repositories and enriched with AI analysis. Always validate rules in a test environment before deploying to production Sentinel workspaces.
View original rule at URLhaus →
Retrieved: 2026-03-19T03:46:59Z · Confidence: medium

Hunt Hypothesis

Hunt package for 32 malicious URLs tagged as ACRStealer

IOC Summary

Threat: ACRStealer Total URLs: 32 Active URLs: 13

URLStatusThreatDate Added
hxxps://4wm0.woodflo.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://unitmed.goodwork.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://checkcipher.besthire.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://serv4base.veloxunit.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://edge3dist.veloxunit.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://node2flow.veloxunit.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://unit1meta.veloxunit.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://main4point.nuxbase.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://data3sync.nuxbase.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://gate2proxy.nuxbase.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://web1infra.nuxbase.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://sat4link.termocenter.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://rock3core.termocenter.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://base2steel.termocenter.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://moon1orbit.termocenter.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://open4space.altasync.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://vast3field.altasync.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://zone2area.altasync.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://rim1outer.altasync.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://path4gate.protovoda.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://view3sync.protovoda.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://scan2point.protovoda.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://room1dark.protovoda.in.net/verification.googleonlinemalware_download2026-03-19
hxxps://sync4vision.luxalabs.in.net/verification.googleofflinemalware_download2026-03-19
hxxps://ghost3node.luxalabs.in.net/verification.googleofflinemalware_download2026-03-19

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: ACRStealer
let malicious_domains = dynamic(["edge3dist.veloxunit.in.net", "gate2proxy.nuxbase.in.net", "room1dark.protovoda.in.net", "unitmed.goodwork.in.net", "link4access.optigrid.in.net", "main4point.nuxbase.in.net", "node2flow.veloxunit.in.net", "data3sync.nuxbase.in.net", "web1infra.nuxbase.in.net", "serv4base.veloxunit.in.net", "4wm0.woodflo.in.net", "unit1meta.veloxunit.in.net", "checkcipher.besthire.in.net"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["edge3dist.veloxunit.in.net", "gate2proxy.nuxbase.in.net", "room1dark.protovoda.in.net", "unitmed.goodwork.in.net", "link4access.optigrid.in.net", "main4point.nuxbase.in.net", "node2flow.veloxunit.in.net", "data3sync.nuxbase.in.net", "web1infra.nuxbase.in.net", "serv4base.veloxunit.in.net", "4wm0.woodflo.in.net", "unit1meta.veloxunit.in.net", "checkcipher.besthire.in.net"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

Original source: https://urlhaus.abuse.ch/