This detection rule identifies adversary activity involving the execution or access of four specific ASCII-tagged malicious URLs known to host threats such as malware and phishing campaigns. A SOC team should proactively hunt for these indicators in Azure Sentinel to rapidly isolate compromised endpoints and prevent lateral movement before attackers can establish persistence within the network.
Threat: ascii Total URLs: 4 Active URLs: 0
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxps://hotelmate.asia/wp-includes/theme-compat/xmorule/qapwsbu/nwshuf1/UWcrypted.ps1 | offline | malware_download | 2026-08-31 |
hxxps://hotelmate.asia/wp-includes/theme-compat/xmorule/qapwsbu/nwshuf1/KMcrypted.ps1 | offline | malware_download | 2026-08-31 |
hxxps://hotelmate.asia/wp-includes/theme-compat/xmorule/qapwsbu/nwshuf1/millscrypted.ps1 | offline | malware_download | 2026-08-31 |
hxxps://hotelmate.asia/wp-includes/theme-compat/xmorule/qapwsbu/nwshuf1/crypted.ps1 | offline | malware_download | 2026-08-31 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: ascii
let malicious_domains = dynamic(["hotelmate.asia"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["hotelmate.asia"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios and corresponding filtering strategies for the URLhaus: ascii Malicious URLs rule in an enterprise environment:
Scenario: Automated Security Tool Health Checks
Source Host or Process Name. Exclude traffic originating from specific security agent processes (e.g., FalconSensor.exe, tmagent.exe) or whitelist the specific IP ranges of your internal threat intelligence gateways.Scenario: Scheduled Software Update Manifest Downloads
NT SERVICE\ccmexec). Alternatively, whitelist the specific destination domains of major software vendors (e.g., *.update.microsoft.com, *.jamfsoftware.com).Scenario: Legacy Reporting Tool Data Ingestion