← Back to SOC feed Coverage →

URLhaus: c2-monitor-auto Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-05-22T11:00:00Z · Confidence: medium

Hunt Hypothesis

The hypothesis is that the detection identifies potential command and control (C2) activity by adversaries using malicious URLs tagged as c2-monitor-auto, which are commonly associated with automated monitoring and persistence mechanisms. SOC teams should proactively hunt for these URLs in Azure Sentinel to identify and disrupt adversarial communication channels and prevent further compromise of the network.

IOC Summary

Threat: c2-monitor-auto Total URLs: 4 Active URLs: 0

URLStatusThreatDate Added
hxxp://91.92.242.236/files-129312398/files/file_db636563c3c4acf5.dll:::Startofflinemalware_download2026-05-22
hxxp://46.224.18.6:8888/Installer.msiofflinemalware_download2026-05-22
hxxp://91.92.242.236/files-129312398/files/file_fd896ea145f39dc0.dll:::Startofflinemalware_download2026-05-22
hxxp://91.92.242.236/files-129312398/files/file_d1f1134c95605cbb.exeofflinemalware_download2026-05-22

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: c2-monitor-auto
let malicious_domains = dynamic(["91.92.242.236", "46.224.18.6"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["91.92.242.236", "46.224.18.6"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/