← Back to SOC feed Coverage →

URLhaus: elf Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-05-10T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be using malicious URLs tagged as elf to deliver payloads or exfiltrate data, leveraging compromised or phishing-based attack vectors. SOC teams should proactively hunt for these URLs in Azure Sentinel to identify and mitigate potential command and control or data exfiltration activities early.

IOC Summary

Threat: elf Total URLs: 9 Active URLs: 9

URLStatusThreatDate Added
hxxp://176.65.139.159/bins/px86onlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/pmpslonlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/x86_64onlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/pmipsonlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/pspconlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/psh4onlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/pppconlinemalware_download2026-05-10
hxxp://176.65.139.159/bins/pm68konlinemalware_download2026-05-10
hxxp://176.65.139.11/bot.i486onlinemalware_download2026-05-10

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: elf
let malicious_domains = dynamic(["176.65.139.159", "176.65.139.11"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["176.65.139.159", "176.65.139.11"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/