This hypothesis targets adversaries leveraging malicious ELF (Executable and Linkable Format) binaries hosted on known URLs to execute initial access or lateral movement within cloud environments. Proactively hunting for these indicators in Azure Sentinel is critical to identify compromised workloads or user sessions that have interacted with these high-severity threats before they establish persistence or exfiltrate data.
Threat: elf Total URLs: 19 Active URLs: 18
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://37.16.74.19/bins/sora.mips | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/main_arm6 | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/main_spc | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.arm7 | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/main_mpsl | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/main_x86 | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.arm5 | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.mpsl | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.spc | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.ppc | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.x86 | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/bins/sora.arm6 | online | malware_download | 2026-09-08 |
hxxp://37.16.74.19/main_x86_64 | online | malware_download | 2026-09-08 |
hxxp://150.40.127.145/hiddenbin/boatnet.arm7 | online | malware_download | 2026-09-08 |
hxxp://150.40.127.145/hiddenbin/boatnet.m68k | online | malware_download | 2026-09-08 |
hxxp://150.40.127.145/hiddenbin/boatnet.arm5 | online | malware_download | 2026-09-08 |
hxxp://150.40.127.145/hiddenbin/boatnet.x86 | offline | malware_download | 2026-09-08 |
hxxp://150.40.127.145/hiddenbin/boatnet.sh4 | online | malware_download | 2026-09-08 |
hxxp://150.40.127.145/hiddenbin/boatnet.spc | online | malware_download | 2026-09-08 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: elf
let malicious_domains = dynamic(["150.40.127.145", "37.16.74.19"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["150.40.127.145", "37.16.74.19"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
artifacts.internal.corp.com) where the User-Agent contains Jenkins, GitHub-Actions, or GitLab-Runner.nmap or masscan that probe external endpoints, including the specific malicious URLs, to verify firewall rules or WAF configurations.
nmap, masscan, or ZAP (Zed Attack Proxy).VeeamBackup, Commvault, or Acronis. Additionally, exclude if the request method is GET and the Content-Type header is application/octet-stream or text/plain (config files) rather than application/x-executable.