← Back to SOC feed Coverage →

URLhaus: jar Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-05-10T23:00:00Z · Confidence: medium

Hunt Hypothesis

The hunt hypothesis detects adversaries using malicious URLs hosted on URLhaus to deliver malicious JAR files, which can execute arbitrary code and establish persistence. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate potential command and control channels and lateral movement tactics.

IOC Summary

Threat: jar Total URLs: 4 Active URLs: 3

URLStatusThreatDate Added
hxxps://donutsmpcheat.com/downloads/float-client.jarofflinemalware_download2026-05-10
hxxps://donutsmpcheat.com/downloads/kryptonite-cracked.jaronlinemalware_download2026-05-10
hxxps://donutsmpcheat.com/downloads/xenon-cracked.jaronlinemalware_download2026-05-10
hxxps://donutsmpcheat.com/downloads/solar-client.jaronlinemalware_download2026-05-10

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: jar
let malicious_domains = dynamic(["donutsmpcheat.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["donutsmpcheat.com"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/