← Back to SOC feed Coverage →

URLhaus: loader Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-05-22T11:00:00Z · Confidence: medium

Hunt Hypothesis

The hypothesis is that the detected URLs are likely used by adversaries to deliver loader malware, which is a common initial compromise technique. SOC teams should proactively hunt for these URLs in Azure Sentinel to identify and mitigate potential lateral movement and persistence threats early.

IOC Summary

Threat: loader Total URLs: 2 Active URLs: 0

URLStatusThreatDate Added
hxxps://get2508.host87p.cfd/?tag=F9zp2cAKofflinemalware_download2026-05-22
hxxps://get4061.host87p.cfd/?tag=F9zp2cAKofflinemalware_download2026-05-22

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat:  loader
let malicious_domains = dynamic(["get2508.host87p.cfd", "get4061.host87p.cfd"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["get2508.host87p.cfd", "get4061.host87p.cfd"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/