This hunt detects adversary behavior where IoT devices or internal systems communicate with known Mirai botnet command-and-control URLs to establish persistence and potential lateral movement. The SOC team should proactively hunt for these indicators in Azure Sentinel because early identification of Mirai-infected endpoints allows for rapid isolation before the compromised assets can propagate malware across the network or launch large-scale DDoS attacks.
Threat: mirai Total URLs: 31 Active URLs: 31
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://120.28.218.170:57492/bin.sh | online | malware_download | 2026-08-31 |
hxxp://106.57.6.80:53331/i | online | malware_download | 2026-08-31 |
hxxp://113.221.75.174:57844/Mozi.a | online | malware_download | 2026-08-31 |
hxxp://115.61.107.195:57147/bin.sh | online | malware_download | 2026-08-31 |
hxxp://125.43.117.183:34827/i | online | malware_download | 2026-08-31 |
hxxp://42.235.235.102:60059/bin.sh | online | malware_download | 2026-08-31 |
hxxp://221.15.173.160:33401/i | online | malware_download | 2026-08-31 |
hxxp://110.136.53.112:38704/i | online | malware_download | 2026-08-31 |
hxxp://210.208.110.42:48170/i | online | malware_download | 2026-08-31 |
hxxp://120.28.199.24:50858/i | online | malware_download | 2026-08-31 |
hxxp://112.198.238.30:58131/bin.sh | online | malware_download | 2026-08-31 |
hxxp://1.61.202.234:46379/bin.sh | online | malware_download | 2026-08-31 |
hxxp://101.108.252.112:37688/bin.sh | online | malware_download | 2026-08-31 |
hxxp://42.235.235.102:60059/i | online | malware_download | 2026-08-31 |
hxxp://27.152.10.10:45145/i | online | malware_download | 2026-08-31 |
hxxp://42.3.52.2:47433/i | online | malware_download | 2026-08-31 |
hxxp://210.208.110.130:35632/bin.sh | online | malware_download | 2026-08-31 |
hxxp://210.208.111.36:38915/i | online | malware_download | 2026-08-31 |
hxxp://120.28.199.24:50858/bin.sh | online | malware_download | 2026-08-31 |
hxxp://113.221.46.46:40057/i | online | malware_download | 2026-08-31 |
hxxp://182.122.193.170:51347/i | online | malware_download | 2026-08-31 |
hxxp://164.163.25.149:34007/i | online | malware_download | 2026-08-31 |
hxxp://125.43.117.183:34827/bin.sh | online | malware_download | 2026-08-31 |
hxxp://210.208.116.107:34736/i | online | malware_download | 2026-08-31 |
hxxp://210.208.106.68:47841/bin.sh | online | malware_download | 2026-08-31 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["106.57.6.80", "112.198.238.30", "120.28.199.24", "210.208.111.36", "109.236.46.215", "193.163.187.75", "113.221.46.46", "110.136.53.112", "113.221.75.174", "42.235.235.102", "115.61.107.195", "42.3.52.2", "101.108.252.112", "210.208.116.107", "164.163.25.149", "210.208.110.130", "123.173.101.81", "210.208.106.68", "1.61.202.234", "27.152.10.10", "182.122.193.170", "210.208.110.42", "221.15.173.160", "210.208.111.26", "120.28.218.170", "125.43.117.183"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["106.57.6.80", "112.198.238.30", "120.28.199.24", "210.208.111.36", "109.236.46.215", "193.163.187.75", "113.221.46.46", "110.136.53.112", "113.221.75.174", "42.235.235.102", "115.61.107.195", "42.3.52.2", "101.108.252.112", "210.208.116.107", "164.163.25.149", "210.208.110.130", "123.173.101.81", "210.208.106.68", "1.61.202.234", "27.152.10.10", "182.122.193.170", "210.208.110.42", "221.15.173.160", "210.208.111.26", "120.28.218.170", "125.43.117.183"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the URLhaus: mirai Malicious URLs detection rule, along with targeted filtering strategies:
IoT Device Firmware Updates & Health Checks
10.50.x.x) or whitelist known vendor update domains such as *.cisco.com, *.arubanetworks.com, and *.hpe.com within the detection logic.Scheduled Security Scanning by EDR Agents
svc-crowdstrike, svc-sentinelone) or filter out requests where the User-Agent string contains keywords like “Falcon”, “SentinelOne”, or “Defender”.Automated Backup and Replication Jobs