This hunt detects adversary behavior where IoT devices or network endpoints access known Mirai botnet command-and-control URLs to establish persistence and prepare for large-scale DDoS attacks. A SOC team should proactively hunt for these indicators in Azure Sentinel to rapidly identify compromised assets before they are recruited into the botnet, thereby preventing potential service disruptions and lateral movement within the environment.
Threat: mirai Total URLs: 22 Active URLs: 22
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://112.113.101.43:53440/i | online | malware_download | 2026-08-17 |
hxxp://115.61.242.68:50097/i | online | malware_download | 2026-08-17 |
hxxp://115.61.242.68:50097/bin.sh | online | malware_download | 2026-08-17 |
hxxp://210.208.111.220:46346/bin.sh | online | malware_download | 2026-08-17 |
hxxp://66.212.173.225:35221/i | online | malware_download | 2026-08-17 |
hxxp://112.198.238.18:53312/i | online | malware_download | 2026-08-17 |
hxxp://112.198.238.18:53312/bin.sh | online | malware_download | 2026-08-17 |
hxxp://60.176.10.219:58446/bin.sh | online | malware_download | 2026-08-17 |
hxxp://117.26.83.196:34302/i | online | malware_download | 2026-08-17 |
hxxp://118.173.224.60:39084/bin.sh | online | malware_download | 2026-08-17 |
hxxp://120.28.144.161:35460/bin.sh | online | malware_download | 2026-08-17 |
hxxp://220.177.11.228:55723/i | online | malware_download | 2026-08-17 |
hxxp://37.157.219.158:39929/i | online | malware_download | 2026-08-17 |
hxxp://210.208.111.36:53831/i | online | malware_download | 2026-08-17 |
hxxp://37.157.219.158:39929/bin.sh | online | malware_download | 2026-08-17 |
hxxp://118.173.224.60:39084/i | online | malware_download | 2026-08-17 |
hxxp://36.70.226.107:53300/bin.sh | online | malware_download | 2026-08-17 |
hxxp://112.113.101.43:53440/bin.sh | online | malware_download | 2026-08-17 |
hxxp://105.186.118.24:44651/i | online | malware_download | 2026-08-17 |
hxxp://180.191.42.15:52214/i | online | malware_download | 2026-08-17 |
hxxp://180.191.34.236:49441/bin.sh | online | malware_download | 2026-08-17 |
hxxp://124.161.116.2:53893/bin.sh | online | malware_download | 2026-08-17 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["115.61.242.68", "37.157.219.158", "118.173.224.60", "180.191.42.15", "124.161.116.2", "220.177.11.228", "210.208.111.36", "180.191.34.236", "120.28.144.161", "210.208.111.220", "112.198.238.18", "36.70.226.107", "105.186.118.24", "66.212.173.225", "112.113.101.43", "60.176.10.219", "117.26.83.196"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["115.61.242.68", "37.157.219.158", "118.173.224.60", "180.191.42.15", "124.161.116.2", "220.177.11.228", "210.208.111.36", "180.191.34.236", "120.28.144.161", "210.208.111.220", "112.198.238.18", "36.70.226.107", "105.186.118.24", "66.212.173.225", "112.113.101.43", "60.176.10.219", "117.26.83.196"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Scenario: IoT Device Firmware Updates
10.50.x.x) and whitelist vendor update domains such as *.meraki.cisco.com or *.ubnt.com. Additionally, filter out traffic where the User-Agent string contains “Meraki” or “UniFi-Controller”.Scenario: Scheduled Security Scanner Jobs
192.168.10.5-10). Implement a rule to ignore alerts where the source port is associated with known scanner daemons (e.g., nessusd, qualyspc) and the destination URL contains keywords like /feed/ or /api/vulnerability.Scenario: Admin Cloud Backup & Replication Tasks