← Back to SOC feed Coverage →

URLhaus: mirai Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-08-30T23:00:00Z · Confidence: medium

Hunt Hypothesis

This detection rule identifies adversary behavior where Mirai malware exploits IoT devices with default credentials to establish command-and-control channels via malicious URLs listed in the URLhaus threat intelligence feed. A SOC team should proactively hunt for this activity within Azure Sentinel because Mirai’s ability to rapidly infect vulnerable IoT infrastructure can lead to large-scale botnet recruitment and potential network-wide disruption if left unaddressed.

IOC Summary

Threat: mirai Total URLs: 16 Active URLs: 16

URLStatusThreatDate Added
hxxp://160.119.71.134/n2/nw/armv6lonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/armv7lonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/mips64bonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/mips64lonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/mpslonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/m68konlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/armv5lonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/sh4onlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/x86onlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/x86_64onlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/aarch64onlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/mipsonlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/ppconlinemalware_download2026-08-30
hxxp://160.119.71.134/n2/nw/armv4lonlinemalware_download2026-08-30
hxxp://165.98.243.83:44647/ionlinemalware_download2026-08-30
hxxp://165.98.243.83:44647/bin.shonlinemalware_download2026-08-30

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["160.119.71.134", "165.98.243.83"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["160.119.71.134", "165.98.243.83"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Here are 4 specific false positive scenarios for the URLhaus: mirai Malicious URLs detection rule in an enterprise environment, along with suggested filters and exclusions:

Original source: https://urlhaus.abuse.ch/