This hypothesis targets the execution of Mirai botnet payloads via known malicious URLs, indicating an active attempt to compromise assets for distributed denial-of-service attacks or lateral movement. Proactively hunting for these indicators in Azure Sentinel allows the SOC to identify compromised endpoints early, preventing the Mirai botnet from propagating across the network and establishing a persistent foothold.
Threat: mirai Total URLs: 26 Active URLs: 26
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://42.243.138.63:36995/i | online | malware_download | 2026-09-14 |
hxxp://42.243.138.63:36995/bin.sh | online | malware_download | 2026-09-14 |
hxxp://210.208.116.107:56842/i | online | malware_download | 2026-09-14 |
hxxp://210.208.116.107:56842/bin.sh | online | malware_download | 2026-09-14 |
hxxp://66.205.236.147:42536/i | online | malware_download | 2026-09-14 |
hxxp://83.233.56.26:42116/bin.sh | online | malware_download | 2026-09-14 |
hxxp://222.127.52.229:34146/i | online | malware_download | 2026-09-14 |
hxxp://223.151.76.13:50733/bin.sh | online | malware_download | 2026-09-14 |
hxxp://42.228.43.131:33505/i | online | malware_download | 2026-09-14 |
hxxp://42.228.43.131:33505/bin.sh | online | malware_download | 2026-09-14 |
hxxp://222.214.101.175:41596/bin.sh | online | malware_download | 2026-09-14 |
hxxp://222.127.52.229:34146/bin.sh | online | malware_download | 2026-09-14 |
hxxp://27.11.15.56:57655/i | online | malware_download | 2026-09-14 |
hxxp://27.11.15.56:57655/bin.sh | online | malware_download | 2026-09-14 |
hxxp://222.127.254.114:44169/bin.sh | online | malware_download | 2026-09-14 |
hxxp://130.12.209.147:59643/i | online | malware_download | 2026-09-14 |
hxxp://210.208.111.36:40065/i | online | malware_download | 2026-09-14 |
hxxp://201.7.230.150:60723/bin.sh | online | malware_download | 2026-09-14 |
hxxp://182.120.38.21:37977/bin.sh | online | malware_download | 2026-09-14 |
hxxp://185.9.139.117:37187/bin.sh | online | malware_download | 2026-09-14 |
hxxp://183.150.192.254:38134/i | online | malware_download | 2026-09-14 |
hxxp://124.6.168.74:45093/i | online | malware_download | 2026-09-14 |
hxxp://210.208.106.68:34920/bin.sh | online | malware_download | 2026-09-14 |
hxxp://182.121.58.91:51347/i | online | malware_download | 2026-09-14 |
hxxp://125.106.119.87:34466/bin.sh | online | malware_download | 2026-09-14 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["210.208.106.68", "125.106.119.87", "114.228.131.16", "201.7.230.150", "183.150.192.254", "130.12.209.147", "42.228.43.131", "83.233.56.26", "66.205.236.147", "222.214.101.175", "182.120.38.21", "42.243.138.63", "210.208.111.36", "182.121.58.91", "222.127.254.114", "223.151.76.13", "222.127.52.229", "124.6.168.74", "185.9.139.117", "27.11.15.56", "210.208.116.107"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["210.208.106.68", "125.106.119.87", "114.228.131.16", "201.7.230.150", "183.150.192.254", "130.12.209.147", "42.228.43.131", "83.233.56.26", "66.205.236.147", "222.214.101.175", "182.120.38.21", "42.243.138.63", "210.208.111.36", "182.121.58.91", "222.127.254.114", "223.151.76.13", "222.127.52.229", "124.6.168.74", "185.9.139.117", "27.11.15.56", "210.208.116.107"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
IoT Device Firmware Updates: Embedded devices (e.g., IP cameras, smart thermostats) or network appliances (e.g., firewalls, load balancers) may periodically poll known Mirai-related update servers or CDN endpoints for firmware patches, especially if the vendor has not fully migrated away from legacy infrastructure.
10.0.0.0/8 (IoT VLAN) or specific device management subnets (e.g., 192.168.10.0/24). Alternatively, whitelist specific user agents or HTTP headers associated with device management tools like curl or wget when the source is a non-workstation asset.Legacy Application Health Checks: Older enterprise applications (e.g., custom Java or .NET services) might use hardcoded URLs for external dependency checks, license validation, or telemetry that coincidentally match a Mirai-tagged URL due to shared hosting or IP reuse.
java.exe, dotnet.exe, iisexpress.exe) and exclude if the destination port is 443 (HTTPS) and the TLS certificate is valid. Add an exclusion for specific service accounts (e.g., svc-app-health) that perform these checks.CI/CD Pipeline Dependency Fetching: Continuous Integration/Deployment pipelines (e.g., Jenkins, GitLab CI, Azure DevOps) may download build artifacts, libraries, or test fixtures from public repositories or CDNs that are tagged as Mirai in URLhaus due to historical compromise or shared infrastructure.
10.20.0.0/24) or processes like `jenkins