This hunt targets adversary behavior where IoT devices or internal systems communicate with known Mirai botnet command-and-control infrastructure via specific malicious URLs identified by URLhaus. Proactively hunting for these connections in Azure Sentinel is critical to detect early-stage botnet infections before they escalate into large-scale DDoS attacks or lateral movement campaigns across the network.
Threat: mirai Total URLs: 10 Active URLs: 10
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://45.194.50.3:43526/i | online | malware_download | 2026-06-29 |
hxxp://196.188.135.20:45066/i | online | malware_download | 2026-06-29 |
hxxp://85.11.167.201/nz/nz.mips | online | malware_download | 2026-06-29 |
hxxp://85.11.167.201/nz/nz.x86 | online | malware_download | 2026-06-29 |
hxxp://117.57.51.29:39515/bin.sh | online | malware_download | 2026-06-29 |
hxxp://196.188.135.20:45066/bin.sh | online | malware_download | 2026-06-29 |
hxxp://91.92.42.232/bins.sh | online | malware_download | 2026-06-29 |
hxxp://143.20.185.89/bins/px86 | online | malware_download | 2026-06-29 |
hxxp://143.20.185.89/bins/parm6 | online | malware_download | 2026-06-29 |
hxxp://143.20.185.89/bins/parm7 | online | malware_download | 2026-06-29 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["196.188.135.20", "117.57.51.29", "85.11.167.201", "91.92.42.232", "45.194.50.3", "143.20.185.89"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["196.188.135.20", "117.57.51.29", "85.11.167.201", "91.92.42.232", "45.194.50.3", "143.20.185.89"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the URLhaus: Mirai Malicious URLs detection rule in an enterprise environment, along with suggested filters or exclusions:
Automated Firmware Update Scans by Network Management Tools
*.cisco.com, *.ubnt.com). Additionally, filter for HTTP status codes 200 or 304 to ensure only successful, expected polling traffic is ignored.Scheduled Vulnerability Assessment Scans
02:00 - 04:00 UTC). Alternatively, add an exception for traffic where the User-Agent string contains identifiers like Tenable.Nessus,