← Back to SOC feed Coverage →

URLhaus: mirai Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-09-06T11:00:01Z · Confidence: medium

Hunt Hypothesis

This hypothesis targets the presence of known Mirai botnet command-and-control (C2) URLs, indicating that an adversary is actively managing compromised IoT or embedded devices to facilitate botnet operations. Proactively hunting for these specific indicators in Azure Sentinel allows the SOC to identify lateral movement or persistent footholds within the network before the botnet can be leveraged for large-scale DDoS attacks or further exploitation.

IOC Summary

Threat: mirai Total URLs: 5 Active URLs: 5

URLStatusThreatDate Added
hxxp://82.144.86.37:56329/ionlinemalware_download2026-09-06
hxxp://36.64.184.26:46567/ionlinemalware_download2026-09-06
hxxp://196.190.105.170:49217/bin.shonlinemalware_download2026-09-06
hxxp://36.64.184.26:46567/bin.shonlinemalware_download2026-09-06
hxxp://207.188.90.227:44244/ionlinemalware_download2026-09-06

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["196.190.105.170", "82.144.86.37", "36.64.184.26", "207.188.90.227"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["196.190.105.170", "82.144.86.37", "36.64.184.26", "207.188.90.227"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/