This rule detects potential Mirai botnet infections by identifying traffic to known malicious URLs associated with the Mirai malware, which is frequently used for initial compromise or command-and-control communications. Proactively hunting for these indicators in Azure Sentinel allows the SOC team to identify compromised endpoints early, preventing the lateral movement and DDoS amplification typical of Mirai botnets before they impact network performance.
Threat: mirai Total URLs: 25 Active URLs: 25
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://85.173.24.109:50492/bin.sh | online | malware_download | 2026-09-05 |
hxxp://85.173.24.109:50492/i | online | malware_download | 2026-09-05 |
hxxp://222.127.63.230:37978/bin.sh | online | malware_download | 2026-09-05 |
hxxp://207.188.90.226:37720/i | online | malware_download | 2026-09-05 |
hxxp://130.12.209.147:43312/bin.sh | online | malware_download | 2026-09-05 |
hxxp://138.204.196.254:38435/i | online | malware_download | 2026-09-05 |
hxxp://222.127.63.230:37978/i | online | malware_download | 2026-09-05 |
hxxp://36.71.59.91:38018/i | online | malware_download | 2026-09-05 |
hxxp://180.190.186.97:52355/bin.sh | online | malware_download | 2026-09-05 |
hxxp://115.58.180.245:33235/i | online | malware_download | 2026-09-05 |
hxxp://117.63.112.125:41376/i | online | malware_download | 2026-09-05 |
hxxp://120.28.193.113:43151/bin.sh | online | malware_download | 2026-09-05 |
hxxp://119.116.121.152:35357/bin.sh | online | malware_download | 2026-09-05 |
hxxp://45.177.32.104:36577/i | online | malware_download | 2026-09-05 |
hxxp://115.51.108.246:51347/i | online | malware_download | 2026-09-05 |
hxxp://182.116.76.200:57147/i | online | malware_download | 2026-09-05 |
hxxp://112.198.238.18:46799/bin.sh | online | malware_download | 2026-09-05 |
hxxp://112.198.193.5:40399/bin.sh | online | malware_download | 2026-09-05 |
hxxp://112.198.193.5:40399/i | online | malware_download | 2026-09-05 |
hxxp://114.227.56.205:36941/bin.sh | online | malware_download | 2026-09-05 |
hxxp://114.227.56.205:36941/i | online | malware_download | 2026-09-05 |
hxxp://45.177.32.104:36577/bin.sh | online | malware_download | 2026-09-05 |
hxxp://120.28.215.200:60458/i | online | malware_download | 2026-09-05 |
hxxp://138.204.196.254:38435/bin.sh | online | malware_download | 2026-09-05 |
hxxp://222.127.54.84:59994/i | online | malware_download | 2026-09-05 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["180.190.186.97", "222.127.54.84", "207.188.90.226", "114.227.56.205", "182.116.76.200", "115.58.180.245", "138.204.196.254", "120.28.193.113", "85.173.24.109", "117.63.112.125", "222.127.63.230", "115.51.108.246", "119.116.121.152", "112.198.238.18", "112.198.193.5", "130.12.209.147", "36.71.59.91", "120.28.215.200", "45.177.32.104"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["180.190.186.97", "222.127.54.84", "207.188.90.226", "114.227.56.205", "182.116.76.200", "115.58.180.245", "138.204.196.254", "120.28.193.113", "85.173.24.109", "117.63.112.125", "222.127.63.230", "115.51.108.246", "119.116.121.152", "112.198.238.18", "112.198.193.5", "130.12.209.147", "36.71.59.91", "120.28.215.200", "45.177.32.104"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
192.168.10.0/24) or specific device MAC addresses from the URLhaus alert if the destination URL matches a known Mirai C2 domain and the source is a non-critical IoT asset.SEC-1234) and suppress alerts for source IPs associated with the red team jump host (e.g., 10.20.5.10) during the defined test window.VeeamAgent.exe, CommCell.exe) and the connection occurs during the scheduled backup verification window (e.g., Sundays 02:00–