← Back to SOC feed Coverage →

URLhaus: mirai Malicious URLs

ioc-hunt HIGH URLhaus
CommonSecurityLogDnsEvents
iocurlhaus
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at URLhaus →
Retrieved: 2026-09-08T23:00:00Z · Confidence: medium

Hunt Hypothesis

This hunt targets the presence of known Mirai botnet command-and-control (C2) URLs to identify hosts potentially compromised by this IoT-focused malware. Proactively hunting for these indicators in Azure Sentinel is critical because Mirai often propagates via brute-force attacks on exposed services, allowing adversaries to establish persistent footholds that can be leveraged for lateral movement or distributed denial-of-service (DDoS) attacks.

This hunt targets the presence of known Mirai botnet command-and-control (C2) URLs to identify hosts potentially compromised by this IoT-focused malware. Proactively hunting for these indicators in Azure Sentinel is critical because Mirai often propagates via brute-force attacks on exposed services, allowing adversaries to establish persistent footholds that can be leveraged for lateral movement or distributed denial-of-service (DDoS) attacks.

IOC Summary

Threat: mirai Total URLs: 17 Active URLs: 1

URLStatusThreatDate Added
hxxp://196.189.98.110:47834/bin.shofflinemalware_download2026-09-08
hxxp://196.189.197.131:53908/iofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.i686offlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.sh4offlinemalware_download2026-09-08
hxxp://176.65.139.139/launch.shonlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.ppcofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.arcofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.mipsofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.x86_64offlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.arm7offlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.arm5offlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.x86offlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.arm6offlinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.spcofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.m68kofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.mpslofflinemalware_download2026-09-08
hxxp://176.65.139.139/reflect.armofflinemalware_download2026-09-08

KQL: Url Dns Hunt

// Hunt for DNS resolution of URLhaus malicious domains
// Threat: mirai
let malicious_domains = dynamic(["176.65.139.139"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc

KQL: Url Proxy Hunt

// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["176.65.139.139"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc

Required Data Sources

Sentinel TableNotes
CommonSecurityLogEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://urlhaus.abuse.ch/