This hypothesis targets the presence of Mozi botnet-related URLs, which are frequently used for command-and-control (C2) communications or initial payload delivery in IoT and server environments. Proactively hunting for these indicators in Azure Sentinel allows the SOC to identify compromised assets early, preventing the Mozi botnet from propagating lateral movement or executing malicious tasks before they impact operational systems.
Threat: Mozi Total URLs: 46 Active URLs: 46
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://42.238.161.249:46152/i | online | malware_download | 2026-09-15 |
hxxp://60.243.252.219:50588/i | online | malware_download | 2026-09-15 |
hxxp://42.238.161.249:46152/bin.sh | online | malware_download | 2026-09-15 |
hxxp://42.227.202.242:41768/i | online | malware_download | 2026-09-15 |
hxxp://42.236.213.184:45042/bin.sh | online | malware_download | 2026-09-15 |
hxxp://42.224.30.47:41984/i | online | malware_download | 2026-09-15 |
hxxp://42.235.90.147:40161/bin.sh | online | malware_download | 2026-09-15 |
hxxp://39.187.82.248:50808/bin.sh | online | malware_download | 2026-09-15 |
hxxp://42.231.110.122:58966/bin.sh | online | malware_download | 2026-09-15 |
hxxp://42.236.213.184:45042/i | online | malware_download | 2026-09-15 |
hxxp://45.163.68.86:10552/i | online | malware_download | 2026-09-15 |
hxxp://222.141.113.84:50117/bin.sh | online | malware_download | 2026-09-15 |
hxxp://59.96.139.238:53045/bin.sh | online | malware_download | 2026-09-15 |
hxxp://27.194.240.129:53487/i | online | malware_download | 2026-09-15 |
hxxp://27.194.240.129:53487/bin.sh | online | malware_download | 2026-09-15 |
hxxp://42.224.30.47:41984/bin.sh | online | malware_download | 2026-09-15 |
hxxp://42.232.81.235:49679/bin.sh | online | malware_download | 2026-09-15 |
hxxp://222.139.41.139:41068/i | online | malware_download | 2026-09-15 |
hxxp://61.52.1.179:33311/bin.sh | online | malware_download | 2026-09-15 |
hxxp://61.52.1.179:33311/i | online | malware_download | 2026-09-15 |
hxxp://42.232.81.235:49679/i | online | malware_download | 2026-09-15 |
hxxp://42.227.202.242:41768/bin.sh | online | malware_download | 2026-09-15 |
hxxp://61.52.34.120:40800/i | online | malware_download | 2026-09-15 |
hxxp://61.52.198.150:41084/bin.sh | online | malware_download | 2026-09-15 |
hxxp://112.242.157.83:54529/i | online | malware_download | 2026-09-15 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: Mozi
let malicious_domains = dynamic(["39.187.82.248", "112.242.157.83", "59.96.139.238", "222.138.148.176", "222.139.41.139", "115.55.57.245", "42.238.161.249", "61.52.198.150", "61.52.1.179", "42.232.81.235", "45.163.68.86", "60.243.252.219", "42.235.90.147", "27.194.240.129", "222.141.113.84", "42.224.30.47", "42.236.213.184", "42.227.202.242", "61.52.34.120", "42.231.110.122"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["39.187.82.248", "112.242.157.83", "59.96.139.238", "222.138.148.176", "222.139.41.139", "115.55.57.245", "42.238.161.249", "61.52.198.150", "61.52.1.179", "42.232.81.235", "45.163.68.86", "60.243.252.219", "42.235.90.147", "27.194.240.129", "222.141.113.84", "42.224.30.47", "42.236.213.184", "42.227.202.242", "61.52.34.120", "42.231.110.122"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Legacy IoT Device Firmware Updates: Many unmanaged IoT devices (e.g., IP cameras, smart thermostats, or industrial PLCs) running outdated firmware may periodically attempt to connect to known Mozi C2 endpoints for configuration sync or firmware checks if their vendor’s update server was compromised or if the device is misconfigured to use a generic update endpoint that overlaps with a Mozi URL.
IoT-Subnet or VLAN 10.20.0.0/24 from the URL match, or specifically exclude user agents containing IPCamera, PLC, or Thermostat if the Mozi URL is accessed via HTTP (not HTTPS) from these segments.Backup Software Repository Sync: Enterprise backup solutions like Veeam, Commvault, or Acronis may use specific HTTP endpoints to verify repository integrity or download plugin updates. If a Mozi URL is hosted on a domain that is also used for a public software repository or CDN (e.g., cdn.example.com), the backup agent’s scheduled job (e.g., Daily-Backup-Sync at 02:00 AM) might trigger the rule when it polls the endpoint.
vbrservice.exe, cvpp.exe, or acrbackup.exe when the destination URL matches the Mozi list, or exclude traffic from the Backup-Server host group if the URL is accessed over port 80/443 during the defined backup window.Web Application Caching/CDN Purging: When developers deploy new assets, they may manually trigger CDN cache purging via HTTP GET requests to specific URLs. If a Mozi URL is inadvertently included in a shared CDN domain or if a developer uses a Mozi-tagged URL as a