This hypothesis targets the execution of the Mozi botnet, a prevalent IoT and Linux malware that often propagates via compromised web servers or phishing links, by identifying known malicious URLs associated with its distribution. Proactively hunting for these indicators in Azure Sentinel is critical to detect early-stage infections and prevent the botnet from establishing command-and-control channels or initiating lateral movement within the environment.
Threat: Mozi Total URLs: 16 Active URLs: 16
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://27.207.188.79:59273/bin.sh | online | malware_download | 2026-09-28 |
hxxp://123.13.2.39:33633/bin.sh | online | malware_download | 2026-09-28 |
hxxp://59.97.248.189:34242/bin.sh | online | malware_download | 2026-09-28 |
hxxp://115.57.245.213:56769/i | online | malware_download | 2026-09-28 |
hxxp://115.53.195.106:39456/bin.sh | online | malware_download | 2026-09-28 |
hxxp://115.63.13.240:59501/bin.sh | online | malware_download | 2026-09-28 |
hxxp://123.11.65.9:34637/i | online | malware_download | 2026-09-28 |
hxxp://42.225.200.15:45467/i | online | malware_download | 2026-09-28 |
hxxp://115.56.156.34:59704/i | online | malware_download | 2026-09-28 |
hxxp://182.127.70.195:58077/bin.sh | online | malware_download | 2026-09-28 |
hxxp://27.207.230.96:35260/i | online | malware_download | 2026-09-28 |
hxxp://59.97.248.167:40553/i | online | malware_download | 2026-09-28 |
hxxp://182.121.150.197:36353/i | online | malware_download | 2026-09-28 |
hxxp://123.14.220.67:47907/i | online | malware_download | 2026-09-28 |
hxxp://115.48.150.244:36092/bin.sh | online | malware_download | 2026-09-28 |
hxxp://182.127.125.58:44880/i | online | malware_download | 2026-09-28 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: Mozi
let malicious_domains = dynamic(["27.207.230.96", "182.121.150.197", "115.53.195.106", "115.57.245.213", "59.97.248.189", "182.127.70.195", "182.127.125.58", "123.14.220.67", "59.97.248.167", "42.225.200.15", "115.48.150.244", "115.63.13.240", "115.56.156.34", "123.13.2.39", "27.207.188.79", "123.11.65.9"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["27.207.230.96", "182.121.150.197", "115.53.195.106", "115.57.245.213", "59.97.248.189", "182.127.70.195", "182.127.125.58", "123.14.220.67", "59.97.248.167", "42.225.200.15", "115.48.150.244", "115.63.13.240", "115.56.156.34", "123.13.2.39", "27.207.188.79", "123.11.65.9"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
curl or wget to download a specific Mozi-infected binary or configuration file from a known URL for local analysis, debugging, or creating a test fixture in a non-production environment.
curl.exe, wget.exe, or powershell.exe and the destination path contains keywords like \test\, \dev\, \sandbox\, or \analysis\.Nessus or Qualys that references a list of known malicious URLs (including Mozi) to verify if any internal hosts are still fetching resources from them.
nessus.exe, qualys_agent.exe) or where the user account belongs to the Service_Accounts or Scanner group.cmd.exe or powershell.exe and the command line contains keywords like logrotate, archive, backup, or cleanup.w3wp.exe, nginx.exe, apache.exe) and the user account is