This hunt targets the presence of known Mozi botnet command-and-control URLs, which adversaries use to establish persistent remote access and execute malicious payloads on compromised hosts. Proactively hunting for these indicators in Azure Sentinel allows the SOC team to identify potentially infected assets before the botnet can propagate laterally or initiate large-scale DDoS attacks.
Threat: Mozi Total URLs: 5 Active URLs: 5
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://42.226.67.57:56542/i | online | malware_download | 2026-09-08 |
hxxp://182.126.116.12:55360/bin.sh | online | malware_download | 2026-09-08 |
hxxp://27.215.124.53:58552/i | online | malware_download | 2026-09-08 |
hxxp://222.142.253.114:60129/i | online | malware_download | 2026-09-08 |
hxxp://222.142.253.114:60129/bin.sh | online | malware_download | 2026-09-08 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: Mozi
let malicious_domains = dynamic(["182.126.116.12", "42.226.67.57", "222.142.253.114", "27.215.124.53"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["182.126.116.12", "42.226.67.57", "222.142.253.114", "27.215.124.53"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
svc-inventory-app) or the source IP range of the legacy application server from the URL match.admin-data-migration) or limit the alert to only trigger if the URL is accessed by more than 5 unique hosts within a 1-hour window.BackupVerify.bat) initiated by the backup service account (svc-backup) makes a GET request to a Mozi URL to confirm that the backup repository is reachable and not blocked by the firewall.
svc-backup service account or the specific scheduled task name (\Backup\VerifyConnectivity) from the detection logic.hosts file or proxy rule.
dev or test in the asset inventory, or exclude traffic originating from the developer’s specific workstation IP if it is within the dev subnet (e.g., `10.20.0.0/2