This hypothesis targets the Mozi botnet, a prevalent IoT malware family that leverages compromised devices to establish command-and-control channels via known malicious URLs. Proactively hunting for these indicators in Azure Sentinel allows the SOC to identify potentially compromised endpoints or network traffic before the botnet can propagate, execute lateral movement, or initiate distributed denial-of-service attacks.
Threat: Mozi Total URLs: 35 Active URLs: 35
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://182.126.201.152:43849/bin.sh | online | malware_download | 2026-09-03 |
hxxp://42.224.78.23:39508/bin.sh | online | malware_download | 2026-09-03 |
hxxp://61.144.102.183:42035/bin.sh | online | malware_download | 2026-09-03 |
hxxp://182.126.201.152:43849/i | online | malware_download | 2026-09-03 |
hxxp://182.119.68.47:43814/bin.sh | online | malware_download | 2026-09-03 |
hxxp://222.137.175.220:33354/i | online | malware_download | 2026-09-03 |
hxxp://27.193.158.205:55721/i | online | malware_download | 2026-09-03 |
hxxp://202.1.26.13:41939/bin.sh | online | malware_download | 2026-09-03 |
hxxp://182.124.20.96:57190/bin.sh | online | malware_download | 2026-09-03 |
hxxp://103.203.210.102:46614/bin.sh | online | malware_download | 2026-09-03 |
hxxp://119.179.236.55:53616/bin.sh | online | malware_download | 2026-09-03 |
hxxp://123.10.225.139:46476/i | online | malware_download | 2026-09-03 |
hxxp://115.63.84.231:59738/bin.sh | online | malware_download | 2026-09-03 |
hxxp://115.63.84.231:59738/i | online | malware_download | 2026-09-03 |
hxxp://42.235.84.132:35722/i | online | malware_download | 2026-09-03 |
hxxp://115.51.63.21:33583/bin.sh | online | malware_download | 2026-09-03 |
hxxp://115.62.181.25:57183/bin.sh | online | malware_download | 2026-09-03 |
hxxp://119.179.236.55:53616/i | online | malware_download | 2026-09-03 |
hxxp://182.119.183.62:55474/i | online | malware_download | 2026-09-03 |
hxxp://115.55.173.148:44037/i | online | malware_download | 2026-09-03 |
hxxp://182.119.183.62:55474/bin.sh | online | malware_download | 2026-09-03 |
hxxp://112.230.155.183:39618/i | online | malware_download | 2026-09-03 |
hxxp://61.53.88.100:45611/i | online | malware_download | 2026-09-03 |
hxxp://115.55.244.240:35253/bin.sh | online | malware_download | 2026-09-03 |
hxxp://221.1.226.106:47537/i | online | malware_download | 2026-09-03 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: Mozi
let malicious_domains = dynamic(["115.55.244.240", "182.119.183.62", "182.124.20.96", "182.119.68.47", "182.121.224.68", "115.55.173.148", "123.10.225.139", "115.63.84.231", "2.187.98.47", "61.144.102.183", "202.1.26.13", "42.224.78.23", "27.193.158.205", "112.230.155.183", "182.126.201.152", "96.125.128.2", "61.53.88.100", "103.203.210.102", "119.179.236.55", "47.215.224.64", "115.62.181.25", "42.235.84.132", "221.1.226.106", "222.137.175.220", "115.51.63.21"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["115.55.244.240", "182.119.183.62", "182.124.20.96", "182.119.68.47", "182.121.224.68", "115.55.173.148", "123.10.225.139", "115.63.84.231", "2.187.98.47", "61.144.102.183", "202.1.26.13", "42.224.78.23", "27.193.158.205", "112.230.155.183", "182.126.201.152", "96.125.128.2", "61.53.88.100", "103.203.210.102", "119.179.236.55", "47.215.224.64", "115.62.181.25", "42.235.84.132", "221.1.226.106", "222.137.175.220", "115.51.63.21"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Scenario: IoT/OT Device Firmware Updates
10.20.0.0/16) or specific device asset tags (e.g., asset_type=iot_gateway) when the destination URL matches the Mozi list but the User-Agent string contains firmware-updater or vendor-sync.Scenario: Legacy Application Health Checks
ping or health-check HTTP GET request to a third-party monitoring service (e.g., Pingdom, New Relic, or a custom internal status page) that happens to be hosted on a domain/IP recently added to the Mozi URLhaus list due to a shared hosting provider.GET, the response status code is 200 or 301, and the User-Agent contains legacy-app-healthcheck or the source process is identified as java.exe with a specific JAR file name (e.g., legacy-erp.jar).Scenario: Scheduled Backup Verification Jobs
backup_verify.ps1) run by a service account to validate backup integrity by making a lightweight HTTP request to a remote storage endpoint (e.g., Azure Blob Storage or AWS S3) that uses a temporary pres