This rule detects the presence of known Mozi botnet command-and-control URLs, indicating that an adversary is actively communicating with or downloading payloads from a compromised infrastructure. Proactively hunting for these indicators in Azure Sentinel allows the SOC team to identify compromised endpoints early, preventing the Mozi botnet from establishing persistence and executing lateral movement across the network.
Threat: Mozi Total URLs: 11 Active URLs: 7
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://219.157.161.10:60183/i | online | malware_download | 2026-09-05 |
hxxp://27.210.37.1:42263/i | online | malware_download | 2026-09-05 |
hxxp://219.157.161.10:60183/bin.sh | online | malware_download | 2026-09-05 |
hxxp://125.43.26.183:35880/i | offline | malware_download | 2026-09-05 |
hxxp://182.126.107.136:58026/i | online | malware_download | 2026-09-05 |
hxxp://125.43.26.183:35880/bin.sh | offline | malware_download | 2026-09-05 |
hxxp://112.246.19.248:41316/i | online | malware_download | 2026-09-05 |
hxxp://59.180.145.116:53945/i | offline | malware_download | 2026-09-05 |
hxxp://70.166.118.40:37408/i | online | malware_download | 2026-09-05 |
hxxp://182.126.116.9:54149/bin.sh | offline | malware_download | 2026-09-05 |
hxxp://27.210.249.141:42418/i | online | malware_download | 2026-09-05 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: Mozi
let malicious_domains = dynamic(["182.126.107.136", "219.157.161.10", "27.210.249.141", "112.246.19.248", "70.166.118.40", "27.210.37.1"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["182.126.107.136", "219.157.161.10", "27.210.249.141", "112.246.19.248", "70.166.118.40", "27.210.37.1"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
svc-app-health, api-gateway-admin) or specific source IPs belonging to the application server cluster from the URL match criteria.jenkins-agent, gitlab-runner, azure-devops-agent) or specific user contexts (e.g., ci-service-account) when the URL request originates from the build server subnet.svc-backup, commvault-agent) or specific scheduled task names (e.g., Daily-Backup-Job, Sync-Files) from the detection logic.