This hunt detects adversary activity where endpoints access known Mozi malware distribution URLs to facilitate initial infection or lateral movement within the network. Proactive hunting in Azure Sentinel is critical because Mozi’s rapid propagation through these specific malicious links can lead to widespread compromise if not identified and isolated before it spreads across the environment.
Threat: Mozi Total URLs: 48 Active URLs: 48
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxp://182.126.118.161:54312/bin.sh | online | malware_download | 2026-08-23 |
hxxp://115.98.147.69:48442/i | online | malware_download | 2026-08-23 |
hxxp://125.41.1.142:60668/i | online | malware_download | 2026-08-23 |
hxxp://125.47.32.24:44968/i | online | malware_download | 2026-08-23 |
hxxp://115.49.6.248:33966/i | online | malware_download | 2026-08-23 |
hxxp://115.60.223.148:58418/i | online | malware_download | 2026-08-23 |
hxxp://115.42.71.239:50213/i | online | malware_download | 2026-08-23 |
hxxp://182.113.205.36:51969/bin.sh | online | malware_download | 2026-08-23 |
hxxp://42.225.15.213:35530/bin.sh | online | malware_download | 2026-08-23 |
hxxp://125.44.38.130:50257/i | online | malware_download | 2026-08-23 |
hxxp://222.136.52.188:32973/bin.sh | online | malware_download | 2026-08-23 |
hxxp://42.239.76.28:33921/bin.sh | online | malware_download | 2026-08-23 |
hxxp://66.8.135.142:58566/i | online | malware_download | 2026-08-23 |
hxxp://182.112.6.161:53066/bin.sh | online | malware_download | 2026-08-23 |
hxxp://182.113.205.36:51969/i | online | malware_download | 2026-08-23 |
hxxp://115.57.255.1:59779/i | online | malware_download | 2026-08-23 |
hxxp://115.42.71.239:50213/bin.sh | online | malware_download | 2026-08-23 |
hxxp://42.224.100.62:51333/i | online | malware_download | 2026-08-23 |
hxxp://222.141.138.63:42485/bin.sh | online | malware_download | 2026-08-23 |
hxxp://103.160.130.109:34175/i | online | malware_download | 2026-08-23 |
hxxp://115.55.49.244:41600/i | online | malware_download | 2026-08-23 |
hxxp://115.55.55.56:36789/bin.sh | online | malware_download | 2026-08-23 |
hxxp://219.155.81.115:40911/bin.sh | online | malware_download | 2026-08-23 |
hxxp://115.52.190.88:42242/i | online | malware_download | 2026-08-23 |
hxxp://115.98.147.69:48442/bin.sh | online | malware_download | 2026-08-23 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: Mozi
let malicious_domains = dynamic(["125.44.38.130", "115.55.49.244", "42.224.100.62", "115.42.71.239", "42.239.76.28", "93.88.96.103", "115.57.255.1", "115.60.223.148", "27.204.195.233", "115.49.24.80", "125.47.32.24", "115.98.147.69", "222.141.138.63", "103.160.130.109", "182.126.118.161", "115.55.55.56", "42.225.15.213", "115.52.190.88", "219.155.81.115", "222.136.52.188", "66.8.135.142", "115.49.6.248", "182.113.205.36", "125.40.24.46", "125.41.1.142", "182.112.6.161"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["125.44.38.130", "115.55.49.244", "42.224.100.62", "115.42.71.239", "42.239.76.28", "93.88.96.103", "115.57.255.1", "115.60.223.148", "27.204.195.233", "115.49.24.80", "125.47.32.24", "115.98.147.69", "222.141.138.63", "103.160.130.109", "182.126.118.161", "115.55.55.56", "42.225.15.213", "115.52.190.88", "219.155.81.115", "222.136.52.188", "66.8.135.142", "115.49.6.248", "182.113.205.36", "125.40.24.46", "125.41.1.142", "182.112.6.161"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios for the URLhaus: Mozi Malicious URLs detection rule in an enterprise environment, along with suggested filters or exclusions:
Scenario: Automated Software Update Scanners
CROWDSTRIE-SVC, MSDEFENDER-UPD) or filter out HTTP/HTTPS requests where the User-Agent string contains keywords like “Falcon,” “Defender,” or “UpdateService” and the response code is 200 OK without subsequent process execution.Scenario: Scheduled Backup and Archiving Jobs
Veeam-Prod-Daily) and limit the scope to specific backup server FQDNs (e.g., backup-prod01.corp.local). Additionally, filter out traffic occurring strictly during maintenance windows (e.g., 02: